1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with code on a bespoke addon xml and other code help needed thanx

Discussion in 'Custom Service/Development Requests' started by Ian S, Dec 3, 2014.

  1. Ian S

    Ian S Active Member

    hi all i need your help please on a bespoke add on that was made for or dev xf test site, basically i exported it and then when i tried to get it to import on a fresh copy it wouldnt work and i got the error attached below
    ive traced it down to this code in the xml addon file

    <route_type type="admin">
    <prefix original_prefix="adverts" class="RTOC_Route_PrefixAdmin_Adverts" build_link="data_only"/>
    <prefix original_prefix="directory-categories" class="RTOC_Route_PrefixAdmin_DirectoryCategory" build_link="data_only"/>
    <prefix original_prefix="wizard-categories" class="RTOC_Route_PrefixAdmin_WizardCategory" build_link="data_only"/>
    <route_type type="public">
    <prefix original_prefix="directory" class="RTOC_Route_Prefix_Directory" build_link="data_only"/>
    <prefix original_prefix="events" class="RTOC_Route_Prefix_Events" build_link="data_only"/>
    <prefix original_prefix="wizard" class="RTOC_Route_Prefix_Wizard" build_link="data_only"/>

    ive noticed that when i removed these line above the addon installed but the other attached pic at bottom the rtoc bespoke bar on the left wasnt there and i couldnt get into the rotating ad part from anywhere else that i could see, its strange as i upgraded the original install of xf from v1.3 to 1.4.3 which works but as soon as i try to put the addon on a fresh install as i need to do a complete vb import it wont work without removing these lines of code

    anyone help on this, im not a coder but want to get this dev site working fully so we can finally use xf properly and drop the vb site, thanx as always

    Attached Files:

  2. rainmotorsports

    rainmotorsports Well-Known Member

    Are the files uploaded because an invalid class suggests the file with that class is missing.
  3. Ian S

    Ian S Active Member

    they are mate yes infact i didnt delete them, i just cleared db put on master db and then tried to import the addon when i got the error
  4. Ian S

    Ian S Active Member

  5. Ian S

    Ian S Active Member

    ok i found out today that it because the categories were not created in the admin templates etc, is there abit of code i could add to get this to import the code is above that wont work thanx

Share This Page