Help - Problems Awarding Trophy Points based on Message Count

Steve Freides

Active member
I'm having a show-stopper problem with Trophy Points, please help.

For information only as this is working as expected:
ACP -> Users -> User Title Ladder

Enable Trophies is enabled
User title ladder field = Trophy Points

2 entries:
"First Post", Minimum Value = 1
"Tenth Post", Minimum Value = 10

Where the problem is:
ACP -> Users -> Trophies

2 entries:
"First Post", Trophy Points = +1, Award this trophy if ... User has posted at least X messages = 1
"Tenth Post", Trophy Points = +9, Award this trophy if ... User has posted at least X messages = 10

User Luk... has posted 447 message and shows 10 points
User Veg... has posted 971 messages and shows 1 point - this is wrong!

Both users show primary group as Registered, and the only secondary group each is a member of is Verified (happens in the new user promotion after 3 posts).

Both user joined after our forum was rolled over from a WP-based forum to XP in 2015.

The Big Question:
What is wrong with the way the points are being awarded? Both users should have 10 points.
 

Lukas W.

Well-known member
This can pretty much depend on any number of factors. What's important to know is that the cron entry that awards trophies only processes users that have been online within the last (iirc) two hours. So if you created your first post trophy at a different time than your 10th post trophy, the user may simply hasn't logged in to receive it since.
 

Steve Freides

Active member
@Lukas W., it's now the next day and the problem persists. I could go into Tools and rebuild all the caches. Do you recommend that, or do you or anyone else have any other ideas?

I also just noticed, in Editing this user, that their trophy points are shown and can be changed. Can you or anyone else tell me how the number shown in Users -> Edit interacts with the cron job in the awarding of trophy points.

-S-
 

Steve Freides

Active member
I see my cron entry is set to run day = "Any" and no specific time, and it says it will be run in a few minutes so it seems to have chosen 0800 to run. I will look again shortly since that time occurs in a just a few minutes.

-S-
 

Steve Freides

Active member
No, I had not done that. How is this different than the Update User Trophies in the list of cron jobs, please? I did, as previously mentioned, run that.

Rebuilding all caches solved the problem.

Thank you.

-S-
 

Brogan

XenForo moderator
Staff member
The cron task applies to recently active members only.

The rebuild task applies to all members, regardless how long they have been absent from the site.
 

Steve Freides

Active member
@Brogan, thank you. Two trophy questions for you or anyone who knows:

If I Rebuild Trophies, will that cause them to be awarded again from scratch?

Is there a way to prevent users from receiving alerts about the having been given a trophy, either something they can configure for themselves or something I can configure to turn off the alerts for everyone or a group of people?

-S-
 
Top