1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Having issues with fastcgi php handler

Discussion in 'General PHP and MySQL Discussions' started by XxUnkn0wnxX, Feb 23, 2014.

  1. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    well i had this problem for a while some of my add ones don't seem to work well with this and also i am using user friendly URLs with the htaccess mod re write rules that the xenforo installation came with i modified it a bit to my own needs as in i added more re write rules but when i went from suphp to fastcgi my site started to run faster and smoother but also started up some issues.

    i am not 100% where the fastcgi.conf is i know where php.conf is and where all my Apache conf files are.

    i am using php 5.4.x

    some of my add ones that use CGI have issues such as waindigo's user upgrades add one i have contacted him several times and he said it configuration on my server. i know other site suffers the same issue but they havent fixed it on there and i haven't figured out what is wrong:

    so is there any proper documentation on how to properly configure xenforo to with with fastcgi? any settings/files need to be edited?

    and the errors i get from some add ones are issues with magic magic fatel error:
    "Fatal Error: Call to undefined method"

    also issues with user upgrades add one giving me errors such as this:

    [​IMG]

    i believe that when a user tries to buy something they press on the buy link but the link doesn't generate properly and it doesn't include the sellers email. therefore giving an error i think it a fastcgi mis configuration some where but i not sure how to fix this.

    this what i have in my forums folder well a peace of it i wont show the rest due to security reasons:

    Code:
    #The top of your .htaccess file
    ServerSignature Off
    RewriteEngine On
    IndexIgnore *
    
    # Protect your .htaccess file
    <Files .htaccess>
            order allow,deny
            deny from all
    </Files>
    
    <Files admin.php>
    AuthType Basic
    AuthName "Username and password required"
    AuthUserFile /home/unkn0wn/.htpasswd2
    Require valid-user
    </Files>
    
    
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 400 default
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        RewriteCond %{HTTP_HOST} ^www.portalcentric.net/forums$ [NC]
        RewriteRule ^(.*)$ http://portalcentric.net/forums/$1 [R=301,L]
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        RewriteBase /forums
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data|js|styles|install) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    now some one told me i need to have the htaccess file as htaccess.txt not .htaccess as the hidden format which i have always had

    also a friend told me to do this but i don't understand any of this:

    Code:
    [23/02/2014 9:58:06 pm] .:: TeOzSec ::.: location /xf/ {
    try_files $uri $uri/ /xf/index.php?$uri&$args;
    index index.php index.html;
    }
    
    location /xf/internal_data/ {
    internal;
    }
    location /xf/library/ {
           internal;
    }
    
    location ~ \.php$ {
    try_files $uri =404;
    fastcgi_pass    127.0.0.1:9000;
    fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include         fastcgi_params;
    }
    [23/02/2014 9:58:31 pm] .:: TeOzSec ::.: Same thing again, replace /xf/ with /forums/
    [23/02/2014 9:59:20 pm] .:: TeOzSec ::.: Then rename .htaccess to htaccess.txt and see if that makes a difference
     
  2. Sheratan

    Sheratan Well-Known Member

  3. XxUnkn0wnxX

    XxUnkn0wnxX Active Member

    yes i have enable IPN under: My Profile -- > My Selling Tools -- > Instant payment notifications -- > [​IMG]
     

Share This Page