• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
GoodForNothing Avatar On Registration

GoodForNothing Avatar On Registration 1.0.0 Beta 3

No permission to download

Kirk

Well-known member
#1
Last edited:

51463

Well-known member
#4
I tested it on Firefox & Chrome. There is some bugs. Here is the report:

1. When i upload a picture file. It always says " the field avatar was not recongnised" But i am still able to register and the avatar uploads without problems.

1.PNG

2. If i upload a .html file or other non-graphic file. It gives me this error after pressing "submit" to register to the forum.

2.PNG

After i press "back" on the brower to return and upload a real avatar picture. I gives me lots of errors and i am unable to register unless i refresh the page and enter all my information again.

3.PNG


3. Also "Require avatar" is not working. I put all my info and i don't upload an avatar and it doesn't give me an error. It just registers my normally.
I checked the admin panel. And i have "Avatar Required" checked.
 
Last edited:

Kirk

Well-known member
#5
1. When i upload a picture file. It always says " the field avatar was not recongnised" But i am still able to register and the avatar uploads without problems.

We're unable to replicate this error. What version of XF are you using and what version of Chrome and FireFox were you using?


2. If i upload a .html file or other non-graphic file. It gives me this error after pressing "submit" to register to the forum.

We're looking into this.
 

51463

Well-known member
#6
I was using Chrome 43.0.2357.132 m

I'm not sure about Firefox as i don't use it often so i am not familiar with it.

But it's the newest release, since its on automatic updates
 

51463

Well-known member
#10
I was going to pay a developer to make it for me But since you released it.. I will wait.


I won't donate before it is finished.

But I will donate afterwards if this add-on becomes perfect with no bugs.
 

51463

Well-known member
#14
I am getting this error when i try to upload an avatar.

Code:
Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\forum\library\XenForo\Image\Gd.php on line 78
so increased the settings in php to 190 and i still recieve this message.


Code:
Fatal error: Maximum execution time of 190 seconds exceeded in C:\xampp\htdocs\forum\library\XenForo\Image\Gd.php on line 78

If i disable the add-on and register normally and then i upload the same avatar the normal way through my account settings. I don't get any message or problems.


Add-on
I was first trying with a big avatar 1000 x 1000 , (won't work)
I tried with 500 x 500, (won't work)
I tried with 150 x 150, (works)



Through account settings.
1000 x 1000 (works)
500 x 500 (works)
150 x 150 (works)

For me:
The add-on is not working with big avatars, only with little avatars.

But uploading avatars the normal way.(through account settings) It uploads any size, big or small.
 
Last edited:

51463

Well-known member
#15
Here are the server errors:

Code:
ErrorException: getimagesize(C:\xampp\tmp\phpA626.tmp): failed to open stream: No such file or directory - library\XenForo\Model\Avatar.php:88
Generated By: Unknown Account, 6 minutes ago
Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(2, 'getimagesize(C:...', 'C:\\xampp\\htdocs...', 88, Array)
#1 C:\xampp\htdocs\forum\library\XenForo\Model\Avatar.php(88): getimagesize('C:\\xampp\\tmp\\ph...')
#2 C:\xampp\htdocs\forum\library\GFNRegAvatar\Extend\XenForo\DataWriter\User.php(72): XenForo_Model_Avatar->applyAvatar(5, 'C:\\xampp\\tmp\\ph...')
#3 C:\xampp\htdocs\forum\library\XenForo\DataWriter.php(1423): GFNRegAvatar_Extend_XenForo_DataWriter_User->_postSaveAfterTransaction()
#4 C:\xampp\htdocs\forum\library\XenForo\Model\Avatar.php(228): XenForo_DataWriter->save()
#5 C:\xampp\htdocs\forum\library\GFNRegAvatar\Extend\XenForo\DataWriter\User.php(72): XenForo_Model_Avatar->applyAvatar(5, 'C:\\xampp\\tmp\\ph...')
#6 C:\xampp\htdocs\forum\library\XenForo\DataWriter.php(1423): GFNRegAvatar_Extend_XenForo_DataWriter_User->_postSaveAfterTransaction()
#7 C:\xampp\htdocs\forum\library\XenForo\ControllerPublic\Register.php(416): XenForo_DataWriter->save()
#8 C:\xampp\htdocs\forum\library\GFNRegAvatar\Extend\XenForo\ControllerPublic\Register.php(34): XenForo_ControllerPublic_Register->actionRegister()
#9 C:\xampp\htdocs\forum\library\XenForo\FrontController.php(347): GFNRegAvatar_Extend_XenForo_ControllerPublic_Register->actionRegister()
#10 C:\xampp\htdocs\forum\library\XenForo\FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#11 C:\xampp\htdocs\forum\index.php(13): XenForo_FrontController->run()
#12 {main}
Request State
array(3) {
  ["url"] => string(50) "http://localhost/forum/index.php?register/register"
  ["_GET"] => array(1) {
    ["register/register"] => string(0) ""
  }
  ["_POST"] => array(17) {
    ["username"] => string(0) ""
    ["67a361237a11baa058089c86ff1c8f36"] => string(3) "sda"
    ["avatar_upload"] => string(1) "0"
    ["3e21fc5d1d46e28341694cf7dda3a541"] => string(16) "asdasd@asdsd.com"
    ["0a0d4922da60d7aca449c91f2b27c8af"] => string(0) ""
    ["58794fd4730a6d3a9c68e00ba7c52f75"] => string(0) ""
    ["dob_month"] => string(1) "1"
    ["dob_day"] => string(2) "01"
    ["dob_year"] => string(4) "1984"
    ["73853e454322f88e13023766a76cad1b"] => array(1) {
      ["yzdkoteymdc0mmnjng"] => string(0) ""
    }
    ["custom_fields_shown"] => array(1) {
      [0] => string(18) "yzdkoteymdc0mmnjng"
    }
    ["38b12f528d211e32b34fbd8810da4f26"] => string(19) "America/Los_Angeles"
    ["recaptcha_challenge_field"] => string(206) "03AHJ_VutMLtNOFQbnnQCAFvBEQe7t-ZJexT3dh-vJTw_iA5RyASXpeeOtDU11CS7yQNkYxvuHbkUeltqPiRRrSMlIPaUUABVPEO7rTgdmGZLUsBZE4bM3fowoL5ZAs4FykWIJ2HGiSwYYM8PJX_5pnVSmWqI50kFXDxPJAInVisK_i6KrjcQi74FMhhWDkQHn88WBUd5oDFzo"
    ["recaptcha_response_field"] => string(4) "1224"
    ["agree"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "c7d9120742cc6efea06cb634f990e219"
  }
}


Code:
Error Info
ErrorException: Fatal Error: Maximum execution time of 190 seconds exceeded - library\XenForo\Image\Gd.php:277
Generated By: Unknown Account, 11 minutes ago
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Request State
array(3) {
  ["url"] => string(50) "http://localhost/forum/index.php?register/register"
  ["_GET"] => array(1) {
    ["register/register"] => string(0) ""
  }
  ["_POST"] => array(19) {
    ["username"] => string(0) ""
    ["97545a54aac72d611e4972e4bc51614e"] => string(5) "test5"
    ["avatar_upload"] => string(1) "0"
    ["0a9c322c612499794b0a068bd3d9f161"] => string(0) ""
    ["3341de1f6dfb99c104659a21e21c0a88"] => string(14) "dasd@asdds.com"
    ["password"] => string(8) "********"
    ["7793cf25ec3e77ee693e39c9b6ca680a"] => string(0) ""
    ["3b4af8b9a4df9989ae142a30aabd2f32"] => string(0) ""
    ["dob_month"] => string(1) "1"
    ["dob_day"] => string(1) "1"
    ["dob_year"] => string(4) "1984"
    ["b892a0eac16a3e45afcee4ea31b73d9c"] => array(1) {
      ["nzc1yze1oty"] => string(0) ""
    }
    ["custom_fields_shown"] => array(1) {
      [0] => string(11) "nzc1yze1oty"
    }
    ["7492e3154d9543c02fd0d03dbb6205f7"] => string(19) "America/Los_Angeles"
    ["recaptcha_challenge_field"] => string(206) "03AHJ_VutVsyrIHtKYrDes5noUlIq_2wiMvBP_LqLtu0gwqw3g0ljVc1qVoqVYwwVatxxGKLTxhWFPb6J5ndtmnLkiGiNgjHmIJCRDpABacVSnSwxrM2NyKGk7LVF7Yew5ks00hWT_F9cOScWSkhZIj2auoyhpG1IzRxDycnRSlNRyUHzPRgzcEmRthnxEtILo37WJojK4cnH2"
    ["recaptcha_response_field"] => string(4) "5139"
    ["agree"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "775c1596b1952e500e4c065df1b204a5"
  }
}
 

zoldos

Well-known member
#16
Got this error upon a member's registration. The avatar appears to have been successfully uploaded regardless:

Code:
ErrorException: Fatal Error: Maximum execution time of 120 seconds exceeded - library/XenForo/Image/Gd.php:186
Generated By: Unknown Account, Today at 5:43 PM
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Request State
array(3) {
["url"] => string(58) "http://www.xxx.net/index.php?register/register"
["_GET"] => array(1) {
["register/register"] => string(0) ""
}
["_POST"] => array(16) {
["username"] => string(0) ""
["c9b27263b9a83d84101f7a221377022d"] => string(12) "xxx"
["avatar_upload"] => string(1) "0"
["340212248c47f964cde9e0393704fc8a"] => string(0) ""
["96cf24fadb584241b76e6b838e8dc20b"] => string(21) "xxx@gmail.com"
["password"] => string(8) "********"
["fc5796452a9baf6c479bc5b4c9fb9fb5"] => string(6) "female"
["dob_month"] => string(2) "12"
["dob_day"] => string(2) "23"
["dob_year"] => string(4) "1989"
["location"] => string(14) "hetton le hole"
["7d25ef349dbb075e80865050802b0836"] => string(13) "Europe/London"
["g-recaptcha-response"] => string(420) ["agree"] => string(1) "1"
["_xfToken"] => string(8) "********"
}
}
 

zoldos

Well-known member
#19
Got this error this morning. Seems to have happened when someone tried to change their avatar. I'm guessing it's related as I've never seen it before. I've disabled the mod until it's a bit more stable....

Code:
ErrorException: Fatal Error: imagecreatefromjpeg(): gd-jpeg, libjpeg: recoverable error: - library/XenForo/Image/Gd.php:78
Generated By: xxxa, Today at 6:29 AM
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Request State
array(3) {
  ["url"] => string(123) "http://www.xxx.net/index.php?attachments/do-upload.json&hash=b9fd9d04bd83c59e53bcea706d39cf03&content_type=post"
  ["_GET"] => array(3) {
    ["attachments/do-upload_json"] => string(0) ""
    ["hash"] => string(32) "b9fd9d04bd83c59e53bcea706d39cf03"
    ["content_type"] => string(4) "post"
  }
  ["_POST"] => array(7) {
    ["Filename"] => string(13) "playboy+3.jpg"
    ["content_data"] => array(1) {
      ["post_id"] => string(4) "1711"
    }
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfSessionId"] => string(32) "b82ed96d96acbe2e8a9d9f4ad3153897"
    ["_xfResponseType"] => string(4) "json"
    ["Upload"] => string(12) "Submit Query"
  }
}