1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Gif Avatars

Discussion in 'XenForo Questions and Support' started by saucylost, Mar 1, 2015.

  1. saucylost

    saucylost Member

    Could someone explain how I make that change to have user avatars animate if they want that?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It requires using the Imagemagick option and the relevant extension installed on the server (http://pecl.php.net/package/imagick).

    Note that even without that option, animated avatars will show on profile pages, as long as the image isn't resized or processed in any way.
     
  3. saucylost

    saucylost Member

    So I download 3.2.0RC1 and install it to my host server and in the add-on in the admin panel?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    It's not an add-on, it's a PHP extension so needs to be installed on the server, rather than your XF installation.
     
  5. saucylost

    saucylost Member

    Nice, I just got it :LOL:(y)
     
  6. saucylost

    saucylost Member

    I love how helpful you are Brogan :love:

    Thank you :)
     
  7. saucylost

    saucylost Member

    Okay, I didn't get it. It is only working on the profile which is progress but I would like the images to show on the forum.
     
  8. Amaury

    Amaury Well-Known Member

    Avatars will need to be re-uploaded.
     
  9. saucylost

    saucylost Member

    I removed my AV and uploaded again and it isn't working right yet. I uploaded the package to my host server and extracted the files. I'm missing something here. Do I configure it somewhere?
     
  10. saucylost

    saucylost Member

    I was told by my host that I have ImageMagick 6.6x already installed so what do I need to do?
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Is the imagick PHP PECL extension also installed and has it been compiled against the ImageMagick libraries on the server?

    Have you selected the option in the ACP?
     
  12. saucylost

    saucylost Member

    NVM again, I figured it out for real this time :love:(y)
     
  13. saucylost

    saucylost Member

    That's what I couldn't find but I found an old thread that was having the same issue and found the option to change to ImageMagick PECL Extension for image processing. So happy to have that fixed now :)
     
  14. Nobita.Kun

    Nobita.Kun Well-Known Member

Share This Page