• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Frequent 'Error 502'

Charlie J

Active member
#1
Hey,
I've been having the issue of constantly getting 'Error 502 - Bad Gateway' with my site on Cloudflare,
Running PHP 5.3

Any possible ways to fix?
 

WSWD

Well-known member
#4
Quite often a firewall issue. Have you whitelisted all of Cloudflare's IPs in your firewall, or tried running with your firewall off temporarily?
 

Charlie J

Active member
#5
Quite often a firewall issue. Have you whitelisted all of Cloudflare's IPs in your firewall, or tried running with your firewall off temporarily?
I don't think so ;-; I have the cloudflare thing within my dev site but unsure on my main, I'll check and edit the post.

Edit: i have cloudflare detect enabled
I use centos 6.8
I use php 5.3

Error:
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Can't create a new thread (errno 11); if you are not out of available memory, you can consult the manual for a possible OS-dependent bug - library/Zend/Db/Statement/Mysqli.php:214
 
Last edited:

WSWD

Well-known member
#6
I have no idea what CloudFlare Detect is, but you need to make sure your firewall is not blocking their IPs, assuming you are running some sort of firewall on your server.