• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Forum permissions

#1
http://myevolutionhost.com/forum/index.php#information-announcements.1

I created some forums, and the information and announcements sections I want it so only I or Administrators can post in these forums, how can I set this ?

I looked through the resource section, but didnt have much luck.

Any help would be greatly appreciated.

I also have a section where only my clients will have access to, I created a group called "Clients" and will add my customers to this group, how can I make it so only they can see and view these forums ?
 

Jeremy

Well-known member
#3
In the node tree there is a link titled "Permissions." It will allow you to set node-specific permissions. So you'll want to "Revoke" it on the Registered user group and "Allow" it on the Administrator group.

The same process will apply for the clients only nodes.
 
#4
Thank you gentlemen, I will play around with it here and see what I can figure out.. Its been a couple years since I setup a forum, and this will take some time to get used to.
 

Brogan

XenForo moderator
Staff member
#5
XenForo permissions differ from most, if not all, other forum software.

I would definitely recommend reading those resources to understand how the cumulative nature of them works.
 
#6
As the only administrator in the group, I set my group, user, and node settings all to allow, and I still cant post in this forum, it keeps saying

(You have insufficient privileges to post here.)
 

Martok

Well-known member
#8
As the only administrator in the group, I set my group, user, and node settings all to allow, and I still cant post in this forum, it keeps saying

(You have insufficient privileges to post here.)
ACP > Users > Analyze Permissions

That should show where the problem is.
 

Jeremy

Well-known member
#15
Post permissions can be overridden if you disallow posts to be created within a forum. So make sure the check box that states "Allow new messages to be posted in this forum" is checked in your node settings.