• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Forum Permissions mixed up

Carlos

Well-known member
#1
Alright, so. One of my sites is still on 1.1.2, one day, I decided to make it so that regular members can't start a thread in a particular forum. Then I find out, as an administrator, I can't start a thread.

I go to ACP, and I modify the admin permission for the forum; it doesn't show the "post thread" button. I think I asked this question 2 years ago, but I seem to have forgotten how the permission system works. I even went to the "group options" link on the right - Next to the permission in that forum... What am I missing? What do I need to remember?
 

Carlos

Well-known member
#3
You probably used Never somewhere:

http://xenforo.com/community/resources/understanding-permissions.360/

Don't use Never. For your purposes you should edit the permissions for that specific node. Revoke for Registered and Allow for Administrators.
Okay, based on what you said....

What should I do if I want the following actions to happen:

I created a private forum, only for members 18+ but when I revoke permissions to the forum for Registered Users, I get reports that whoever has access to the 18+ forum can't see it.

How can I make it so that a user can see the forum regardless of the fact that the 18+ usergroup is secondary?

I want it so that everyone else cannot see the forum, but only those that have the access can...?
 

Jake Bunce

XenForo moderator
Staff member
#4
http://xenforo.com/community/resources/understanding-permissions.360/

Creating a private forum

Because of the way Revoke works in xenForo you shouldn't use it to restrict a private forum. Instead you should use a special feature in xenForo called Private node. You will see the Private node checkbox when editing the permissions for a specific node. This basically inverts the permissions so that you can specify Allowed groups instead of Revoked groups. This is actually better for group management if you add more groups later.

Admin CP -> Users -> Node Permissions -> [click Permissions for a forum] -> Private node
 

Martok

Well-known member
#5
For private forums, use the Private Node option. You then have to set the View Node permission to Allow for the group(s) that you want to view it. To everyone else it will not be visible.

EDIT: Ninja'd!
 

Carlos

Well-known member
#6
For private forums, use the Private Node option. You then have to set the View Node permission to Allow for the group(s) that you want to view it. To everyone else it will not be visible.
Hm.

I already had Private Node checked.
I put "Never" on all permissions for 'Registered Users' group.
 

Ingenious

Well-known member
#7
Never use "Never" with private nodes. Just "allow" view node permission (usually you can leave the rest not set) on the usergroups you want to see it.
 

Martok

Well-known member
#10
I did. I only used "never" on usergroups that I DON'T want seeing it.
You shouldn't use NEVER for any usergroup in a private node unless it is to override an ALLOW. For example on my site I have a group that I have allowed access to a private node. I have a further group that has NEVER set. This is for users in the first group who misbehave - I add them to the second group which then prevents them accessing the private node but still keeps them in the first group (with the other privileges that group has. Standard registered users can't see the private node as they haven't been given the ALLOW permission.

Hm.

I already had Private Node checked.
I put "Never" on all permissions for 'Registered Users' group.
That's your problem. ALL forum users should be in this group. You then create other groups with additional privileges and add users to these groups in addition to the registered group, not as a replacement. Anyway, by setting NEVER for registered users on the private node you are preventing all users from accessing it as you cannot override the NEVER permission.
 

Ingenious

Well-known member
#11
No you didn't. I was saying to never use never, but you used "never" as you explained above. As Martok also explains above, you should never use "never". You don't need to. Private node means NO-ONE can view the node at all, period, even admin. Until you go in and "allow" them. Using "never" can screw it up. Step away from the "never" permission :)