1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Forum is not going properly :/ Its my first day with XenForo

Discussion in 'Troubleshooting and Problems' started by Regina Ortega, Feb 5, 2013.

  1. Regina Ortega

    Regina Ortega Active Member

    Well as you can see in the image, everytime that i want to post a reply it show me this error (but the reply is posted.) My Users are avoiding it and press the Reply Buttom Again, so they are doing double post because of it, and also its very annoying :/ How i can solve it? Thanks... Im using CentOs 5, 32 bits with webmin.


    [​IMG]
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That can be the result of a failed or slow SMTP connection (when sending notification emails on reply). A failed SMTP connection will normally show in the log:

    Admin CP -> Tools -> Server Error Log

    If the log contains mail errors then you need to check your SMTP info:

    Admin CP -> Home -> Options -> Email Options

    You can also try adding this line to your library/config.php file to disable mail functions:

    Code:
    $config['enableMail'] = 0;
    
    Does that fix the problem? If so then we know it's a mail problem.
     
    R_A likes this.
  3. Regina Ortega

    Regina Ortega Active Member

    There is no Server Error Log :/

    Server Error Logs
    No errors have been logged.
    I need Help, :/
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    As I said, try disabling emails in the config file to see if that fixes the problem.
     
    R_A likes this.
  5. Regina Ortega

    Regina Ortega Active Member

    There is no such option in my forum/library/config.php

    Just this (ofc with the proper settings):

    PHP:
    <?php
     
    $config
    ['db']['host'] = 'localhost';
    $config['db']['port'] = '3306';
    $config['db']['username'] = '';
    $config['db']['password'] = '';
    $config['db']['dbname'] = '';
     
    $config['superAdmins'] = '1';

    :Help:
     
  6. Regina Ortega

    Regina Ortega Active Member

    O.O There is no fix for it? I will have to leave with it? im starting to havin the Buyer's remorse...
     
  7. HWS

    HWS Well-Known Member

    OT:
    Failed or slow SMTP connections should get an entry in the Bug-List IMHO.

    There should be an asynchronous way to send mail ...
    This is just so annoying and happens all the time with users and incorrect email addresses...

    I your case, there is another error, because SMTP failures are logged.
    I recommend opening a support ticket and ask for help.
     
  8. Regina Ortega

    Regina Ortega Active Member

    So i have to add that line to my config? And it should be like this:

    PHP:
    <?php
     
    $config
    ['db']['host'] = 'localhost';
    $config['db']['port'] = '3306';
    $config['db']['username'] = '';
    $config['db']['password'] = '';
    $config['db']['dbname'] = '';
    $config['enableMail'] = 0;
     
    $config['superAdmins'] = '1';
    Does not it?
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is correct. Does the problem go away when that line is added?
     
    R_A likes this.
  10. Brandon Sheley

    Brandon Sheley Well-Known Member

    should there be ticks around the zero? like

    Code:
    $config['enableMail'] = '0';
     
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    No. It's a boolean.
     
    Brandon Sheley likes this.
  12. Regina Ortega

    Regina Ortega Active Member

    NO, it was my VPS PHP mailing problem. I already fixed formating it and re-installing everything.
     

Share This Page