1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Forced two-step verification keeping me out of admin

Discussion in 'Troubleshooting and Problems' started by John71, Oct 1, 2015.

  1. John71

    John71 New Member

    Hi, While trying to login to my admin account i am being forced to complete the two step verification. I have tried the email type but it isn't sending me the verification code. I have looked into setting an SMTP but, i can't get into the admin to change the settings. Any ideas?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You can temporarily disable 2FA by adding this to the library/config.php file:

    $config['enableTfa'] = false;

    That should then enable you to regain access and disable it for your account - you may also need to check permissions to ensure it isn't being set there.

    Don't forget to remove the line after you have done so.
  3. John71

    John71 New Member

    Where exactly can you enabe/disable the two-step verifications?

    Thank You For The quick reply
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Amin Sabet

    Amin Sabet Well-Known Member

    Hi Brogan, this isn't working for me. I added the line, but still being prompted for TFA. Is there any other way to temporarily disable TFA?
  6. Amin Sabet

    Amin Sabet Well-Known Member

    Nevermind, my mistake, it's working now. Must have needed some time for the settings to take effect. I had cleared cache, but must have missed something.

Share This Page