XF 2.1 [FIXED] XF Latest version + MailGun

whittinghamj

New member
Im new to XF so please forgive me if this is in the wrong place. I have used the search function but was unable to find a solution.

Quick bit of background info. I have tried with / without firewalls on / off. I have added the smtp.mailgun.org IP's to the firewall whitelist.
This is running on cPanel and I have disabled the SMTP Tweak setting that only allows MTA and root users to use external SMTPs.

Here is the error message I get when trying to send email emails or private messages or any email from the XF platform.


  • Swift_TransportException: Email to jamie.whittingham@gmail.com failed: Expected response code 220 but got code "", with message ""
  • src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php:383

  • Generated by: Unknown account
  • Aug 28, 2020 at 8:34 AM


Stack trace​


#0 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php(289): Swift_Transport_AbstractSmtpTransport->_assertResponseCode('', Array)
#1 src/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php(117): Swift_Transport_AbstractSmtpTransport->_readGreeting()
#2 src/XF/Mail/Mailer.php(274): Swift_Transport_AbstractSmtpTransport->start()
#3 src/XF/Mail/Queue.php(138): XF\Mail\Mailer->send(Object(Swift_Message), Object(Swift_SmtpTransport), Array)
#4 src/XF/Job/MailQueue.php(12): XF\Mail\Queue->run(G)
#5 src/XF/Job/Manager.php(253): XF\Job\MailQueue->run(G)
#6 src/XF/Job/Manager.php(195): XF\Job\Manager->runJobInternal(Array, G)
#7 src/XF/Job/Manager.php(79): XF\Job\Manager->runJobEntry(Array, G)
#8 job.php(42): XF\Job\Manager->runQueue(false, 8)
#9 {main}


Request state​


array(4) {
["url"] => string(8) "/job.php"
["referrer"] => string(54) "https://iptvuplink.com/index.php?conversations/test.1/"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}


The odd thing is, its not even trying to make an outbound connection as when I use the wrong user / pass on purpose, the error message is the same.

I also tried with an internal cPanel SMTP account and get the same results so I'm 99% sure its not a MailGun issue.

Any advice would be great, thanks so much.
 
Top