XF 2.2 Firefox not showing sub forum in columns

Dixie McCall

Well-known member
Howdy,
I have my sub forums in four columns but Firefox is showing them in one long column. Is there a work around for this?

see attached.

I'm using this code.
.node-subNodeFlatList {
display: block;
width: 700px;
columns: 150px 4;

}
.node-subNodeFlatList li {
width: 100%;
float: left;
font-size: 12px;
}

Thank you kindly,

Finn
 

Attachments

  • Screenshot (58).png
    Screenshot (58).png
    145.7 KB · Views: 6
  • Screenshot (57).png
    Screenshot (57).png
    70.7 KB · Views: 6

Dixie McCall

Well-known member
Hello djbaxter,
Yes I think I got part of my code from that thread but for some reason FF isn't showing them in column mode but Chrome is.

What the heck am I doing wrong?
 
Last edited:

djbaxter

Well-known member
I use Firefox as my default browser.

Your code also includes width settings for both the block and the columns. Those may need to be adjusted down a bit, especially if the subforums have long titles (although they do wrap but not necessarily in the way you want - you may also need to edit the node titles — that wont mess anything up for search engines as long as you haven't removed. the .xxxxxx node number at the end).

I think on the forum I used that CSS I was not able to display 4 columns with a sidebar and had to settle for just two. It still looks neater that way though.
 

djbaxter

Well-known member
I'm using this code.
.node-subNodeFlatList {
display: block;
width: 700px;
columns: 150px 4;

}
.node-subNodeFlatList li {
width: 100%;
float: left;
font-size: 12px;
}
Something @Russ helped me with recently. Try adding !important to your CSS:

CSS:
.node-subNodeFlatList {
display: block !important;
width: 700px !important;
columns: 150px 4 !important;
}

.node-subNodeFlatList li {
width: 100% !important;
float: left !important;
font-size: 12px !important;
}

If it still doesn't work, I don't know what to say.
 
Top