1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 File Health Check Notice

Discussion in 'Installation, Upgrade, and Import Support' started by sophie1204, Feb 19, 2012.

  1. sophie1204

    sophie1204 Active Member

    I did it! I finally installed xenforo. Things went great until I ran a file health check and got the following notice:

    library/XenForo/Model/Permission.phpFile does not contain expected contents.

    What does this mean and what should I do?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Upload the file once more.

    If it still doesn't pass, download the .zip file from your customer area and upload it from there again.

    If you still have a problem, use a different FTP application.
  3. sophie1204

    sophie1204 Active Member

    Did both of those things, and I'm still getting the same notice. :(
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Floris

    Floris Guest

    Same here.
    Downloaded the .zip of 1.1.2 today, and upgrading from 1.0.4, uploaded 3x all the files, and twice this one particularly.
  6. RobParker

    RobParker Well-Known Member

    I used to get this all the time and re-uploading, etc never solved it.

    It disappeared during one of the upgrades when I used FileZilla instead.
  7. mrGTB

    mrGTB Well-Known Member

    I did get this on my localhost install, which I though was odd with one file only (copy and paste) job of files from one folder to another. Deleting file, then downloading zip again and copy that file over fixed it. But I'm sure the file passed File Checking at first, then later failed for some reason even though nothing had been edited in it by me.
  8. Floris

    Floris Guest

    after unpacking upgrade .zip
    ls -fag
    -rw-r--r-- 1 floris staff 70K Apr 19 12:14 Permission.php

    Cmd: STOR Permission.php
    150: Accepted data connection
    226: File successfully transferred
    0.098 seconds (measured here), 0.68 Mbytes per second

    but after upload:

    -rw-r--r-- 1 xenfans xenfans 69600 Apr 19 20:21 Permission.php

    type=file;size=69600;modify=20120419192134;UNIX.mode=0644;UNIX.uid=xxx;UNIX.gid=xxx;unique=xxx; Permission.php

    The problem seems to be only with this file.

    Used Transmit on Mac for ftp and another app from another computer for sftp.
  9. polle

    polle Active Member

    I just did a clean install today and I got the same. I downloaded 1.1.2 today and installed today. After file health check I have the same "library/XenForo/Model/Permission.php File does not contain expected contents.".

    I re uploaded from the zip file and the same. What to do ?

    Floris likes this.
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    polle likes this.
  11. polle

    polle Active Member

    I use Interarchy, by far better than that, so for sure its not my FTP client. I will download again and upload again to see.

  12. polle

    polle Active Member

    Well using FileZilla worked, so for everyone trying with any other FTP client, just use FileZilla for this file.

    Thanks Jake.

Share This Page