1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Fatal error.. Xenforo Session

Discussion in 'Installation, Upgrade, and Import Support' started by woodenlegacy, Apr 9, 2014.

  1. woodenlegacy

    woodenlegacy Member

    Hey everyone, ive just purchased xenforo an have installed it 2 times now, trying separate versions and seem to be getting the same error everything, If someone could please assist me with this error that would be greatly appreciated, if not i just wasted 140$, anyway's here is my error :

    Fatal error: Class 'XenForo_Session' not found in /home/content/path-to-directory/html/forums/library/XenForo/ControllerAdmin/Abstract.php on line 48

    I get this with the latest version of xenforo an xenforo 1.2.1. I have no idea what is causing this after a fresh install once it gives ya the button to go to admin control panel after installation it gives me that error. Thanks for your time.
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Is this a fresh install? Is it on a shared host (if so, who)? If so, does the shared host limit the number of tables you can have in your SQL DB?
    Have you confirmed that all files uploaded correctly?
    And is there a particular reason you reflect 1.2.1 and the prefix is for 1.3? I'm assuming that was a typo.
  3. woodenlegacy

    woodenlegacy Member

    It happens on both, Im not sure if that was proper, but 1.3 and 1.2.1 give me the same error, I am hosting this off of GoDaddy, I put the contents of the 'upload' folder into a /forums directory, everything goes smoothly until the last phase of installation where it gives you the option to continue to the admin panel.
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Looks like you might be missing the library/XenForo/Session.php file. Confirm this. Or more generally, re-upload all files to be sure they are all there.
  5. woodenlegacy

    woodenlegacy Member

    Ive done that 3 seperate times, Once with latest version and twice with 1.2.1, Weirdly enough when I uploaded it to my other site to test it, it worked, but wont work on my main site, which are both on the same hosting plan and company
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Did you confirm the existence of that specific file on your server after the upload?
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  8. woodenlegacy

    woodenlegacy Member

    Yup, I went in and looked at the line its messing up on,

    * Setup the session.
    * @param string $action
    protected function _setupSession($action)
    if (XenForo_Application::isRegistered('session'))

    XenForo_Session::startAdminSession($this->_request); <---(error line #48)

    Ill try another fresh install i guess in that case
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I mean this file:


    Make sure that file exists.
    woodenlegacy likes this.
  10. woodenlegacy

    woodenlegacy Member

    Okay it would appear it wasn't in there, wtf filezilla. I had to use hosting FTP aswell, very strange i'm going to test now and see if it worked

    EDIT : God bless you man, thank you very much for you help that did the trick!
    Last edited: Apr 10, 2014

Share This Page