1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fatal error Image/Gd.php on line 56 (Upgrade attachment)

Discussion in 'Installation, Upgrade, and Import Support' started by phpclub, Nov 4, 2010.

  1. phpclub

    phpclub Member

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 36560 bytes) in xenforo/library/XenForo/Image/Gd.php on line 56
  2. Vladislav Rastrusny

    Vladislav Rastrusny Active Member

    Some more details please. When did it happen? XenForo version?
  3. alik4277

    alik4277 Member

    Same Error on Attachment Import
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Make sure debug mode is off. Remove the debug line from the library/config.php file if you previously added it.

    If you still get the error then you need to ask your host to increase or disable PHP's memory_limit.

    You can also try changing the memory_limit yourself. These methods don't always work, but try adding this to your library/config.php file:

     ini_set('memory_limit', -1);
    Or add this to a .htaccess file on your server (only works on Apache servers):

     php_value memory_limit -1
    Thomas P and alik4277 like this.
  5. alik4277

    alik4277 Member

    With Code om config.php works fine.
    Jake Bunce, Thanks
  6. Vladislav Rastrusny

    Vladislav Rastrusny Active Member

    I think, that allocating 134Mb of memory is a little bit HUGE requirement. Almost every hoster will kill you for such a resource waste.
  7. phpclub

    phpclub Member

    Problem fixed (table attachment ecode to utf-8) - attachment is broken after recode.
    Need add check before create gif image from file.
    Vladislav Rastrusny likes this.

Share This Page