• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

FaceAche is giving me a headache.. Images/avatar not displayed on FaceBook

tenants

Well-known member
#1
Okay, this may or may not be a dev question

I've developed some pages myself..

My issue is that when I recommend a page, the images for my custom pages do not display on Facebook

examples
Thread page works: http://localtutor.co.uk/threads/chemistry-tutoring-by-experienced-medical-student.4346/
Custom page doesn't: http://localtutor.co.uk/tutor/experienced-medical-student-teaching-maths-and-science.10807/

To test this, the page doesn't need to be "recommended", you can just paste the link into Facebook without pressing "post". The forum thread displays an image automatically (the avatar), the custom page doesn't

When viewing the page source and looking at the og data, they are almost identical, so both should show the image
(the og:image is the same on both pages, as is the fb:app_id, both pages contain complete og data in identical ways)

Anyone know why the image doesn't show for the custom page?
 

tenants

Well-known member
#2
argghhh... this is so frustrating, I can't see why one would retrieve the image, but the other wouldn't

Could it be something to do with the way the url in the og:image is formated? Although they both look the same, it's possible one is url encoded and the other isn't (although, from the html source, it doesn't look like this is the case)
 

tenants

Well-known member
#5
Is what a new add-on?

That site is made up of add-ons (no core edits),
Some of it will be too custom for most forums.
I'll release some things related to this site, although I'm still working on it