1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Exporting Style : DOMDocument Not Found.

Discussion in 'Troubleshooting and Problems' started by Draike, Jun 29, 2013.

  1. Draike

    Draike Member

    When attempting to export any style, I receive this error:

    PHP Fatal error: Class 'DOMDocument' not found in /var/www/betterverse/wwwgit/forum/library/XenForo/Model/Style.php on line 448, referer: http://www.betterverse.net/forum/admin.php?styles/


    I recently upgraded from CentOS' official PHP (5.3) to webtatic's php55w, so this is very likely related to that.

    Hoping that this can be resolved without a PHP downgrade.
     
  2. Jeremy

    Jeremy Well-Known Member

  3. Draike

    Draike Member

    Thank you. I was missing two dependencies. I went to Xenforo's installation page (Had to temporarily remove the install lock), and it re-assessed my installation.

    All set now.

    Edit: Appears that I'm mistaken. I'm still seeing
    PHP Fatal error: Call to undefined function mb_internal_encoding() in /var/www/betterverse/wwwgit/forum/library/Lgpl/utf8.php on line 20
    in my logs, though I'm unsure what it stems from.
     
  4. Jeremy

    Jeremy Well-Known Member

    Glad to hear it, you could have also utilized the test script. I highly suggest you replacing the install lock file. (y)
     
  5. Draike

    Draike Member

    I'm not familiar with the test script. Where might I find it?
     
  6. Jeremy

    Jeremy Well-Known Member

  7. Draike

    Draike Member

    Oh, neat. I installed Xenforo ages ago, haven't really messed much with it since.

    As a side note, the remaining error was a result of me not having the mbstring extension for PHP. Yay.
     

Share This Page