1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Errors on copy posts

Discussion in 'Troubleshooting and Problems' started by DaveM, Jun 29, 2015.

  1. DaveM

    DaveM Well-Known Member

    I tried to select a few posts in a thread to copy them to a new thread and I ran the following error

    Code:
    XenForo 1.4.2
    Log out DaveM
    
        Home
        Applications
        Users
        Appearance
        Tools
        Search
        Triumph Motorcycle Forum - TriumphTalk
    
        Tools
    
    Clear Server Error Log
    Server Error Logs
    Server Error Logs
    
        Delete...
        Mysqli prepare error: Unknown column 'allow_view_profile' in 'field list' 2 minutes ago - library/Zend/Db/Statement/Mysqli.php:77
        Delete...
        No entry is registered for key 'session' Saturday at 11:15 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 9:50 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 9:07 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 8:46 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 8:35 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 8:30 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 8:27 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 8:26 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 8:25 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 8:25 AM - library/XenForo/Application.php:997
        Delete...
        No entry is registered for key 'session' Saturday at 8:25 AM - library/XenForo/Application.php:997
    
    Showing 12 of 12 items
    Forum software by XenForo™ ©2010-2014 XenForo Ltd.
    
        Tools
            Cron Entries
            Rebuild Caches
        Diagnostics
            File Health Check
            Test Facebook Integration
            Test Twitter Integration
            Test Image Proxy
        CAPTCHA
            Question and Answer
        Statistics
            Daily Statistics
            Weekly Statistics
            Monthly Statistics
        Logs
            Spam Cleaner Log
            Spam Trigger Log
            Moderator Log
            Admin Log
            User Change Log
            Server Error Log
            Link Proxy Log
            Image Proxy Log
            Email Bounce Log
            Sitemap Log
        Import
            Import External Data
    
    Server Error Log
    Error Info
    Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Unknown column 'allow_view_profile' in 'field list' - library/Zend/Db/Statement/Mysqli.php:77
    Generated By: DaveM, 2 minutes ago
    Stack Trace
    
    #0 /var/www/clients/client0/web1/web/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('INSERT INTO `xf...')
    #1 /var/www/clients/client0/web1/web/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'INSERT INTO `xf...')
    #2 /var/www/clients/client0/web1/web/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('INSERT INTO `xf...')
    #3 /var/www/clients/client0/web1/web/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
    #4 /var/www/clients/client0/web1/web/library/XenForo/Model/Post.php(1633): Zend_Db_Adapter_Abstract->insert('xf_post', Array)
    #5 /var/www/clients/client0/web1/web/library/XenForo/Model/Post.php(1471): XenForo_Model_Post->_copyPost(Array, Array, Array)
    #6 /var/www/clients/client0/web1/web/library/XenForo/Model/Post.php(1377): XenForo_Model_Post->_moveOrCopyPosts('copy', Array, Array, Array, Array)
    #7 /var/www/clients/client0/web1/web/library/XenForo/Model/InlineMod/Post.php(475): XenForo_Model_Post->copyPosts(Array, Array, Array, Array)
    #8 /var/www/clients/client0/web1/web/library/XenForo/Model/InlineMod/Post.php(419): XenForo_Model_InlineMod_Post->_moveOrCopyPosts('copy', Array, Array, Array, Array, NULL)
    #9 /var/www/clients/client0/web1/web/library/XenForo/ControllerPublic/InlineMod/Post.php(231): XenForo_Model_InlineMod_Post->copyPosts(Array, Array, NULL)
    #10 /var/www/clients/client0/web1/web/library/XenForo/ControllerPublic/InlineMod/Post.php(155): XenForo_ControllerPublic_InlineMod_Post->_moveOrCopyPostsAction('canCopyPosts', 'copyPosts', 'XenForo_ViewPub...', 'inline_mod_post...')
    #11 /var/www/clients/client0/web1/web/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_InlineMod_Post->actionCopy()
    #12 /var/www/clients/client0/web1/web/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #13 /var/www/clients/client0/web1/web/index.php(13): XenForo_FrontController->run()
    #14 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(47) "http://www.triumphtalk.com/inline-mod/post/copy"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(9) {
        ["thread_type"] => string(3) "new"
        ["node_id"] => string(2) "22"
        ["prefix_id"] => string(1) "8"
        ["title"] => string(21) "Improving Our Forum 2"
        ["save"] => string(10) "Copy Posts"
        ["posts"] => array(11) {
          [0] => string(6) "231269"
          [1] => string(6) "230971"
          [2] => string(6) "230980"
          [3] => string(6) "230985"
          [4] => string(6) "230992"
          [5] => string(6) "230996"
          [6] => string(6) "231007"
          [7] => string(6) "231022"
          [8] => string(6) "231043"
          [9] => string(6) "231044"
          [10] => string(6) "231268"
        }
        ["_xfConfirm"] => string(1) "1"
        ["redirect"] => string(67) "http://www.triumphtalk.com/threads/improving-our-forum.40598/page-2"
        ["_xfToken"] => string(8) "********"
      }
    }
    
    Delete...
    Close
    
     
  2. Xon

    Xon Well-Known Member

    @DaveM This is the result of an addon not designed for XF 1.3 and up. Hard to tell from that column name which one it would be.
     
  3. DaveM

    DaveM Well-Known Member

    @Xon Ok thanks this will mean I will need to disable each one and see what is causing it
     
    Xon likes this.

Share This Page