Errors from XenForo

Giobi

New member
tried registering on my website and it says error has occurred, I went to admincp and checked logs and here they are ;


#0 /home1/a55network/public_html/forum/library/Zend/Http/Client.php(941): Zend_Http_Client->setAdapter('Zend_Http_Clien...')
#1 /home1/a55network/public_html/forum/library/Zend/Service/ReCaptcha.php(487): Zend_Http_Client->request('POST')
#2 /home1/a55network/public_html/forum/library/Zend/Service/ReCaptcha.php(502): Zend_Service_ReCaptcha->_post('03AHJ_VusboobiN...', '2200 calle')
#3 /home1/a55network/public_html/forum/library/XenForo/Captcha/ReCaptcha.php(53): Zend_Service_ReCaptcha->verify('03AHJ_VusboobiN...', '2200 calle')
#4 /home1/a55network/public_html/forum/library/XenForo/Captcha/Abstract.php(129): XenForo_Captcha_ReCaptcha->isValid(Array)
#5 /home1/a55network/public_html/forum/library/XenForo/ControllerPublic/Register.php(355): XenForo_Captcha_Abstract::validateDefault(Object(XenForo_Input))
#6 /home1/a55network/public_html/forum/library/XenForo/FrontController.php(351): XenForo_ControllerPublic_Register->actionRegister()
#7 /home1/a55network/public_html/forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /home1/a55network/public_html/forum/index.php(13): XenForo_FrontController->run()
#9 {main}


Anyone know the what to do?
 

tenants

Well-known member
In the acp Server Errors, there should be information above that (in the error info?) which sometimes gives a bit more information


for example

Untitled.png

Have you tried turning each of you plugins off one by one ?
(this is kind of my default response for most errors, so sorry, a bit like the common IT solution "have you tried turning your computer off and on again" :) )

ReCaptcha is mentioned in the stack, it might be a timeout, that extra information from the Error Info might tell us more though
 
Last edited:

Giobi

New member
Zend_Http_Client_Exception: Unable to load adapter 'Zend_Http_Client_Adapter_Socket': File "Zend/Http/Client/Adapter/Socket.php" does not exist or class "Zend_Http_Client_Adapter_Socket" was not found in the file - library/Zend/Http/Client.php:844
 

tenants

Well-known member
Was this a one off error, does this error only show in the logs and not the front end

To me, at the moment, it looks like an issue trying to post data to recaptcha but due to missing / corrupt core zend files???
File "Zend/Http/Client/Adapter/Socket.php" does not exist

Have you done anything recently, like a forum upgrade / moved files around / changes hosts / deleted files ?

It might be worth uploading the core xenforo files again to see if this fixes it
 
Top