• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 error

Bombardier

Active member
#1
Getting very frustrated with this one

I recently CHMOD my styles and Js folder to 666 whilst I installed an audentio style
After doing so and when loading my page I got this error meesage in the browsr

Forbidden
You don't have permission to access / on this server.
Server unable to read htaccess file, denying access to be safe.

I have checked all the ,htaccess files for being 644 and I can not resolve this issue.

Any ideas
 

Bombardier

Active member
#2
It seems to me that may have made an error when CHMOD directories?
It would be useful if I knew what each directory should be CHMOD set.
 

Bombardier

Active member
#5
Well this is what they say and coincidentally this issue has happened since they rebooted the server

The reason for the permissions conflicts was due to the servers default
configuration. The server by default will run all PHP scripts under its own
username of "nobody" instead of your accounts username. When this happens
all created files inherit those permissions.

To prevent this you can configure the script wrapper SuEXEC. This will
cause the apache server to run all PHP scripts under your accounts
username. This will prevent any such permissions conflicts from happening
in the future.
 

Bombardier

Active member
#6
just found this on another thread by Brogan

General files and directories should be 0644 and 0755 respectively.

The /data and /internal_data directories should be:
0666/0777 if PHP runs as ""nobody"" (the web server user)
0644/0755 if it runs as ""your"" user (suPHP for example)
 

Bombardier

Active member
#8
And now they say this however with my limited understanding it means nothing to me
When a directory is chmod'ed to 666, the 'execute' bit is removed as
directories treat this a bit differently; when the 'x' is removed from a
directory, access to that directory is effectively blocked.

When chmod'ing such as this is performed, it is necessary to leave out the
directory entries.
 

Tracy Perry

Well-known member
#10
You chmod the files to 666 and the directories to 777. What they (/data and /internal_data) need to have done is be world writeable. If you are conversing with them, simply tell them that those directories and all files and directories below them need to have the files set at 666 and directories at 777. If they don't know how to do that, I'll be happy to whip up a simple little script to do it for them - but if they don't know how to do that, I don't know that I'd want to be hosting with them.

For suPHP, I think there is an option to recompile apache (under EasyApache) with it - but if you are on shared hosting you can't do that.
Is this shared hosting or a VPS with cPanel?
 
Last edited:
#12
Well I have to admit I was getting very frustrated and preparing to throw the towel in for good.
i had one last push and EUREKA! I found that I had changed the permissions on the root folder (God only knows why?) so changed it back and all appears to be working fine.