Error trying to use gmail smtp

Banana Pup

Well-known member
I just found out my host limits mail to 100 per hour so I am trying to set up smtp to use gmail.

Error I get trying to send. I tested only for admin usergroup and get this error even then.

An exception occurred: Mysqli prepare error: MySQL server has gone away in /home/testxf/public_html/library/Zend/Db/Statement/Mysqli.php on line 77
  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
  5. Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Error.php at line 50
  6. XenForo_Error::unexpectedException() in XenForo/Application.php at line 295
  7. XenForo_Application::handleException()
settings are in mail options: port 587 my password

Banana Pup

Well-known member
Oddly though it only happens using remote SMTP, PHP mail it is fine but I need a solution past that as I'm limited to 100 e-mail per hour. It also errors rather quickly like under 30 seconds, could that still be a timeout?

Banana Pup

Well-known member
Thanks Jake, I will point the tech here as he is blaming it on xF and not the server. Recommending I upgrade to a better forum software like myBB or Simple Machines =)

Banana Pup

Well-known member
Ok, they fixed that and after about a minute wait, it confirms it was sent to 1 user, which is correct as I am testing to admin primary group. Now the new issue is using both gmail and several other SMTP servers, no mail arrives to my inbox.

gmail settings I have use port 587
username: password
encryption type: TSL

Jake Bunce

XenForo moderator
Staff member
Then I assume the emails are being sent. But the only way to confirm this is to look at the mail logs. I'm not sure if makes those logs available.

It could also be a spam filter. Check your spam box.

It could also be a problem on the receiving end. An easy way to eliminate that possibility is to send test emails to several different addresses to see if any of them show up.

Jake Bunce

XenForo moderator
Staff member
As an aside, make sure this line does not exist in the library/config.php file:

$config['enableMail'] = 0;
That will disable outgoing mail.

Banana Pup

Well-known member
Nope only things in config are the db settings and $config['superAdmins'] = '1';

The real stumper here is I have tried other STMP including my ISP, my work's and my friends VPS. All send out but nothing arrives to my ISP mail, my work address, my gmail, my domain mail or

Banana Pup

Well-known member
Gonna start looking for a new host.. These guys are just really bad. They can't find anything in the logs and insist my forum would perform much better if I "upgraded" to Simple Machine 2.0 forum /facepalm


Active member
I'd just like to note that if you send many emails from Free GMail SMTP you'll likely get flagged for spam and your account closed.
I was having the same problem. I contact my host, figured it out and hope it starts working any minute. . .

Our problem was the domain was trying to get its emails on hostgators servers when it should have been looking at google's servers for email. Just updated this record and we should start getting emails in about 4-8 hours.

Hope that helps,