XF 2.0 Error (The site is currently being upgraded)

KhanTastic

Active member
Hi friends,

After a long time, I went to my forum and I can see it shows error "The site is currently being upgraded. Please check back later."

I did nothing, I remember the last time I visited my forum, it was working fine. Any idea why I got that problem?
Appreciate your help.

Cheers
 

KhanTastic

Active member
Thanks your reply, when I go to https://mydomain.com/forum/admin.php/install it still says
The site is currently being upgraded. Please check back later.

And when I go to https://mydomain.com/forum/install/ then it shows the following error codes;

An exception occurred: [ErrorException] [E_WARNING] "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in src/XF/Language.php on line 458

  1. XF::handlePhpError() in src/vendor/composer/ClassLoader.php at line 444
  2. include() in src/vendor/composer/ClassLoader.php at line 444
  3. Composer\Autoload\includeFile() in src/vendor/composer/ClassLoader.php at line 322
  4. Composer\Autoload\ClassLoader->loadClass()
  5. spl_autoload_call() in src/XF/Install/Language.php at line 5
  6. include() in src/vendor/composer/ClassLoader.php at line 444
  7. Composer\Autoload\includeFile() in src/vendor/composer/ClassLoader.php at line 322
  8. Composer\Autoload\ClassLoader->loadClass()
  9. spl_autoload_call() in src/XF/Install/App.php at line 153
  10. XF\Install\App->getInstallerLanguage() in src/XF/Install/App.php at line 158
  11. XF\Install\App->setup() in src/XF.php at line 312
  12. XF::setupApp() in src/XF.php at line 324
  13. XF::runApp() in install/index.php at line 14

See if you can have an idea of the issue please.
 

Brogan

XenForo moderator
Staff member
It sounds like your host has upgraded PHP on the server to a version which is not compatible with the version of XF which is running.

Downgrade PHP or upgrade XF.
 

KhanTastic

Active member
Ah I see, currently I have the following in my .htaccess file

<IfModule mime_module>
AddHandler application/x-httpd-ea-php74 .php .php7 .phtml
</IfModule>

Any idea how I can modify these codes? please
 

Brogan

XenForo moderator
Staff member
Change the 4 to a 2.

That may or may not work, depending how the server is configured.
Your host will be able to implement a permanent change/fix.
 

KhanTastic

Active member
I just thought I would renew my support and get one year extension so that I can upgrade my forum and it might solve the issue.
When I purchased the one year extension and renewed my license and went to my site, it was working fine and started loading.

I can not believe XF would shutdown sites when the support expires, I thought its customers choice if they wanna renew the license or not, if they do not renew they have to live with the existing license and are not able to update the site with latest updates and will not get the ticket support.

But, I noticed, XF complete shutdown the site :(

Please tell me I am wrong? This is not fair if this is true :(
 

KhanTastic

Active member
My site was dead from long time as the issue you can see in the original thread above, and I was looking for the solution but I thought I would upgrade my forum and it might help me. As soon I renewed my XF license, the next moment my site started loading fine without any errors. I have not upgraded yet my site but it started working right after renewing the license :(
 

Brogan

XenForo moderator
Staff member
We have no access to the server your site is hosted on, nor is there any backdoor/code or anything else which would enable us to affect your site in any way.

There are many customers running XF installations whose licenses have been expired for years.

Renewals are related to accessing new versions and ticket support only.
 

KhanTastic

Active member
We have no access to the server your site is hosted on, nor is there any backdoor/code or anything else which would enable us to affect your site in any way.

There are many customers running XF installations whose licenses have been expired for years.

Renewals are related to accessing new versions and ticket support only.
Thank you, but from long time I was trying to fix my site, I could not do.
Right after renewing the license, when I went to mt site to upgrade I saw it swas loading 😔
Don't know the truth but that's what has happened.
I'm not trying to lie and gain anything here. I like XF so much, I'm even planning to buy another license and migrate my other mybb forum to XF 😊
 

VBX Co

Active member
Thank you, but from long time I was trying to fix my site, I could not do.
Right after renewing the license, when I went to mt site to upgrade I saw it swas loading 😔
Don't know the truth but that's what has happened.
I'm not trying to lie and gain anything here. I like XF so much, I'm even planning to buy another license and migrate my other mybb forum to XF 😊

It is most likely your host updated something on the server which broke your XF site.

If you were running an older version of XF and your host upgraded PHP to a much newer version, then it will have broken XF.

When you renewed and upgraded XF to the latest version, it will have been able to work on the newer PHP your host installed so might have seemed like and XF issue, but it wasn't. (y) :)

We have been Xenforo customers since the very start, running multiple sites and licenses, and we have NEVER had a site affected by a license expiring. Rest assured, you are in good hands with Xenforo.
 

KhanTastic

Active member
It is most likely your host updated something on the server which broke your XF site.

If you were running an older version of XF and your host upgraded PHP to a much newer version, then it will have broken XF.

When you renewed and upgraded XF to the latest version, it will have been able to work on the newer PHP your host installed so might have seemed like and XF issue, but it wasn't. (y) :)

We have been Xenforo customers since the very start, running multiple sites and licenses, and we have NEVER had a site affected by a license expiring. Rest assured, you are in good hands with Xenforo.
Thanks a lot, I totally understand and agree with you, because my XF was old and I guess my hosting they updated the servers.
But I am just shocked to see, right after renewal license, my site started loading and I did not even transfer new update files that time.

But at least its clear now 100% that our sites will not be down when the license expires :)
It's just a mystery with me, do not know why it happened to me. Thank you for your explanation and all the guys who replied here, great XF team & customers here <3.
 
Top