XF 2.0 Error log? Can someone help?

RoyalSkid

Member
This is sent to me whenever I send a reply to someone's thread....?



InvalidArgumentException: DOMXPath::query(): Invalid expression in selector >> body << in /home/mcgtaor1/public_html/src/vendor/pelago/emogrifier/Classes/Emogrifier.php on line 370 in src/vendor/pelago/emogrifier/Classes/Emogrifier.php at line 1532
  1. Pelago\Emogrifier->handleXpathError()
  2. DOMXPath->query() in src/vendor/pelago/emogrifier/Classes/Emogrifier.php at line 370
  3. Pelago\Emogrifier->process() in src/vendor/pelago/emogrifier/Classes/Emogrifier.php at line 289
  4. Pelago\Emogrifier->emogrify() in src/XF/Mail/Styler.php at line 36
  5. XF\Mail\Styler->styleHtml() in src/XF/Mail/Mailer.php at line 189
  6. XF\Mail\Mailer->renderMailTemplate() in src/XF/Mail/Mail.php at line 277
  7. XF\Mail\Mail->renderTemplate() in src/XF/Mail/Mail.php at line 315
  8. XF\Mail\Mail->getSendableMessage() in src/XF/Mail/Mail.php at line 346
  9. XF\Mail\Mail->queue() in src/XF/Notifier/Post/AbstractWatch.php at line 128
  10. XF\Notifier\Post\AbstractWatch->sendEmail() in src/XF/Service/AbstractNotifier.php at line 92
  11. XF\Service\AbstractNotifier->notifyType() in src/XF/Service/AbstractNotifier.php at line 44
  12. XF\Service\AbstractNotifier->notify() in src/XF/Service/AbstractNotifier.php at line 56
  13. XF\Service\AbstractNotifier->notifyAndEnqueue() in src/XF/Service/Thread/Replier.php at line 199
  14. XF\Service\Thread\Replier->sendNotifications() in src/XF/Pub/Controller/Thread.php at line 300
  15. XF\Pub\Controller\Thread->finalizeThreadReply() in src/XF/Pub/Controller/Thread.php at line 433
  16. XF\Pub\Controller\Thread->actionAddReply() in src/XF/Mvc/Dispatcher.php at line 249
  17. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 88
  18. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
  19. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1894
  20. XF\App->run() in src/XF.php at line 328
  21. XF::runApp() in index.php at line 13
 

Brogan

XenForo moderator
Staff member
Are you running PHP 7.3 on the server?

If so, only XF versions 2.0.12 and later are compatible with it.
 
Top