XF 2.2 ERR_TOO_MANY_REDIRECTS only on the main page with Apple / IOS devices (Safari)

MrFrancis

New member
Hello, for some time now more and more members on an Apple machine (most of the time on a phone under IOS) are unable to access the home page of the site. I have been looking for a solution for several days now, but nothing is giving any good news. Users who have this bug are stuck only on the homepage, it may very well go to /whats-new/ or watch a thread. I was able to discuss it with users who had this problem and we have already tried together to change their browser settings and clear the cache of course. The home page, on the other hand, works fine on a computer or with a recently updated browser. Here is the link to the report for you to read and test for yourself: https://www.webpagetest.org/result/210728_AiDcD7_02dbee97e0884c885e8b4f19f125d575/


URL friendly is enabled and canonization too.
I checked that my basic settings in the options started with https: //
My SSL certificate is activated.
My .htacess is the default one, I followed all the steps I had to do when I activated the friendly URL:
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php74” package as the default “PHP” programming language.
<IfModule mime_module>
  AddHandler application/x-httpd-ea-php74 .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit

I attach all the images that I think necessary. Thank you in advance to those who will help me, I absolutely have to solve this problem
 

Attachments

  • GSC error.PNG
    GSC error.PNG
    365.8 KB · Views: 8
  • options.PNG
    options.PNG
    52.8 KB · Views: 8
  • pain chrome main page.png
    pain chrome main page.png
    153.3 KB · Views: 8
  • pain safari main page.png
    pain safari main page.png
    68.8 KB · Views: 7
  • safari error1.jpg
    safari error1.jpg
    14.1 KB · Views: 7
  • safari error2.jpg
    safari error2.jpg
    16.1 KB · Views: 8

MrFrancis

New member
I have the impression that this problem is there from the beginning (maybe when the frendly urls and all the basic configuration were done). here is my addon list, none are supposed to redirect.

1627473163557.png
 

djbaxter

Well-known member
Have you tried specifying RewriteBase?

Code:
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
    RewriteBase /
 

djbaxter

Well-known member
Are you experiencing this issue yourself or is it just certain members? If you can replicate the problem yourself, try clearing your cookies as suggested by the webpagetest.org page.

You can also suggest that to any members having the issue. They can clear cookies by manually logging out of your forum and then logging back in.


See below.
 
Last edited:

djbaxter

Well-known member
Are you experiencing this issue yourself or is it just certain members? If you can replicate the problem yourself, try clearing your cookies as suggested by the webpagetest.org page.

You can also suggest that to any members having the issue. They can clear cookies by manually logging out of your forum and then logging back in.
Ignore this.

I get the error when I try to access your site in Safari from my iPhone and I'm not even logged in. In fact, I get the error long before it even sets any cookies.

And it's not just Safari. Same error is displayed in Firefox and Chrome. With Edge, it just says it can't reach the page but I would assume it's the same problem.
 
Last edited:

Brogan

XenForo moderator
Staff member
It works for me with Windows/Chrome and I don't have any apple devices to test with.

I suspect something server side as the .htaccess file is more or less standard and the ACP settings are correct.

Try disabling engintron.
 

MrFrancis

New member
It's probably time to submit a ticket to the Xenforo support team.
Done, I am now awaiting an answer ...

It works for me with Windows/Chrome and I don't have any apple devices to test with.

I suspect something server side as the .htaccess file is more or less standard and the ACP settings are correct.

Try disabling engintron.
It seems to me that I cannot do that myself, I have to contact my host.

FWIW, I can access your site on my iPad (Safari/iPadOS) without issues.
This is what makes this bug very strange ... Some get there while others don't.
 

kimchuy

Member
Have you tried using the default theme on xenforo? it seems that it redirects https to http on your homepage..

Also you may using NGINX and not APACHE.. meaning your .htaccess has no value even you delete that file..
 
Last edited:

MrFrancis

New member
Have you tried using the default theme on xenforo? it seems that it redirects https to http on your homepage..
I would have to try this but it would really amaze me if it came from there.

Also you may using NGINX and not APACHE.. meaning your .htaccess has no value even you delete that file..
I assure you that my .htaccess is functional.

For experiment, try disable board URL canonicalization.
/admin.php?options/groups/basicBoard/#boardUrlCanonical
I have already tried several times and the error remains the same unfortunately.
 
Top