• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Entire forum minus main page non-functional

#1
Hello Xenforo,

To explain my issue:
  1. I upgraded my system from Ubuntu 14.04 to 16.x (forget which exact one).
  2. Backed up and carried all my files and sql data over.
  3. Setup everything again.
  4. Upgraded to latest 1.5 XF version
Now I cannot access anything on my forum except the main page.

I tried the following things:
  • Changed /forum/.htaccess to
    • RewriteBase /forum.blackout-ro.net (the folder my forum in installed in)
  • Checked that mod rewrite is enabled.
  • chmod 777 to data and internal_data folders
  • Installed php-gd
Link: http://forum.blackout-ro.net
 

Brogan

XenForo moderator
Staff member
#2
It looks like a Friendly URLs issue to me.

Disable that in the ACP until you resolve it on the server.
 

CTXMedia

Formerly CyclingTribe
#6
Changed /forum/.htaccess to
RewriteBase /forum.blackout-ro.net (the folder my forum in installed in)
Change it back to /forum/ if you have installed XF in a sub-directory called /forum/ - if not, leave it hashed-out (or set it back to default #RewriteBase /xenforo)

Then check your web server settings to ensure it is using the sub-domain to serve the site: forum.blackout-ro.net (as opposed to the default www or primary domain)

Then copy the contents of your .htaccess file and paste it here. (y)
 
Last edited:
#7
Change it back to /forum/ if you have installed XF in a sub-directory called /forum/ - if not, leave it hashed-out (or set it back to default #RewriteBase /xenforo)

Then check your web server settings to ensure it is using the sub-domain to serve the site: forum.blackout-ro.net (as opposed to the default www or primary domain)

Then copy the contents of your .htaccess file and paste them here. (y)
I tried both commenting and uncommenting the RewriteBase line, no luck.
Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /forum

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
   
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
   
</IfModule>

<Files admin.php>
    Order Deny,Allow
    Deny from all
    Allow from all
</Files>
 

CTXMedia

Formerly CyclingTribe
#8
Can you access admin.php? If so, in Basic Board Information, what entries do you have for?
  • Board URL
  • Index Page Route
 
#14
Are you sure mod_rewrite is enabled?
It turns out I hadn't done everything properly. I was following this guide: https://www.digitalocean.com/commun...set-up-mod_rewrite-for-apache-on-ubuntu-14-04

Instead of putting my <Directory> stuff in sudo nano /etc/apache2/sites-enabled/000-default.conf
I need to put it in /etc/apache2/apache2.conf where I already have my virtualhost setup.

Thank you very much to both Brogan and CyclingTribe, good sirs.

This is why XenForo is the best! Great software, great community and helpers.