• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Enforce Post Rules 1.0.1

No permission to download

Robbo

Well-known member
#1
Robbo submitted a new resource:

Enforce Post Rules (version 1.0) - Specify forums where your users have to agree to post rules and terms.

Enforce Post Rules allows you to apply rules or conditions of creating a thread within specific nodes on your forum. After installing and configuring, members will be prompted to check a box stating they have read the node rules with a link to those rules. If a user does not agree to the rules they will be unable to create the thread.
Read more about this resource...
 

yavuz

Well-known member
#2
Robbo first at all thank you for doing this addon and sharing it with the community. Most of the users either ignore the "Terms of Use" or "Forum Rules". This adds a extra layer to ensure they do. However from experience, I think the majority will just check and not read what the site administration wants them to to read.

Instead (or as a feature) would it be possible to redirect them to a "Terms of Use" page, where there would be a counter which they couldn't ignore until the countdown is over (x amount of time) and when it's time the check box activates automatically? Specifying which user group will be enforced to this is another thing I would like this addon do.
 

Robbo

Well-known member
#3
I can't put anymore time to this add-on and the system you have described seems like something that would drive users away. I would most likely not post on such a forum. This is more of a legal type of thing. It can hold up in court and you can delete/moderate without warning as it is assumed they have read the rules/terms.
 

Alien

Well-known member
#4
Perhaps this could be offered as a compromise...

Consider maybe an extra box located under the reply box with a scrollable version of the rules page, so you never have to open another browser window to read them. Then the "I agree" can be located underneath?
 

Robbo

Well-known member
#5
There are other things I could do with this. Like being able to add rules in the ACP and then show them however I don't have time. The current method is effective and will be the last update for at least a year now. Unless there are some weird bugs found.
 

gldtn

Well-known member
#6
Robbo, if the terms are a bit to big for the screen, when I have Open this link in an overlay.. I can't scrool down on the overlay, not allowing people to read the rest of the terms specified.

Is there an easy edit I can do on my side to make this happen since you said you can't really put more time in this mod for now?

Thanks!
 

Robbo

Well-known member
#7
Nope. That is a XenForo limitation and as designed, either put the terms into a overflow: auto; or just don't use an overlay?
 

Luis

Well-known member
#8
This Addon is causing to me this error when creating a forum and save it; when the Addon installed but not activated. Version xenForo is 1.1.2

error.png


sinsele.png
 

Robbo

Well-known member
#9
What other add-ons do you have installed? Looks like the changes to the forum datawriter aren't being accepted. I can see where to get rid of this error but it would still mean the add-on wouldn't work in general. Sounds like a bad add-on not following XenForo inheritance is causing this.
 
#11
Hi,

I installed the addon into my xenforo, but when I activate the plugin at a forum I'm getting the following error:

xf-error.png

Has someone any ideas about that?

Regards,
Markus
 
#14
I've tested it on my local installation with PHP 5.3, there it works, on our server we have PHP 5.4 running, so I think there are some problems with that?
 

ashkir

Active member
#15
I'd love an update for PHP 5.4.

Also, we have a debates forum where this would be awesome for. Is there a way to expand this to cover any new post?
 

AdamD

Well-known member
#19
Fresh Xenforo install and I get the same problem listed above:

  • The field 'require_post_rules' was not recognised.
  • The field 'post_rules_url' was not recognised.
  • The field 'post_rules_overlay' was not recognised.
When adding a sibling/child forum.
Doesn't seem to do it for categories, just new/existing childs.
 

Daniel 'RTRD'

Well-known member
#20
Fresh Xenforo install and I get the same problem listed above:

  • The field 'require_post_rules' was not recognised.
  • The field 'post_rules_url' was not recognised.
  • The field 'post_rules_overlay' was not recognised.
When adding a sibling/child forum.
Doesn't seem to do it for categories, just new/existing childs.
Same problem here.