• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Emailing Error

JpA

Active member
#1
Hi so I recently logged into my admin panel and found these errors:
Code:
Zend_Mail_Transport_Exception: Email to orangekittyx3@yahoo.com failed: Unable to send mail. - library/Zend/Mail/Transport/Sendmail.php:137
Generated By: Unknown Account, Tuesday at 12:56 AM
Stack Trace
#0 /var/www/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /var/www/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /var/www/library/XenForo/Model/MailQueue.php(79): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
#3 /var/www/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(7.9999980926514)
#4 /var/www/library/XenForo/Model/Deferred.php(294): XenForo_Deferred_MailQueue->execute(Array, Array, 7.9999980926514, '')
#5 /var/www/library/XenForo/Model/Deferred.php(428): XenForo_Model_Deferred->runDeferred(Array, 7.9999980926514, '', false)
#6 /var/www/library/XenForo/Model/Deferred.php(373): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#7 /var/www/deferred.php(23): XenForo_Model_Deferred->run(false)
#8 {main}
Request State
array(3) {
  ["url"] => string(36) "http://killswitchmc.com/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(46) "/index.php?threads/new-shop-items-factions.25/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  }
}
Here is another Error i'm getting all of these errors are talking about some sort of emails:
Code:
Zend_Mail_Transport_Exception: Email to mjg267106@gmail.com failed: Unable to send mail. - library/Zend/Mail/Transport/Sendmail.php:137
Generated By: HiPower, Monday at 5:37 AM
Stack Trace
#0 /var/www/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /var/www/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /var/www/library/XenForo/Mail.php(175): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
#3 /var/www/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#4 /var/www/library/XenForo/Model/UserConfirmation.php(136): XenForo_Mail->send('mjg267106@gmail...', 'HiPower')
#5 /var/www/library/XenForo/ControllerPublic/AccountConfirmation.php(104): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
#6 /var/www/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_AccountConfirmation->actionResend()
#7 /var/www/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /var/www/index.php(13): XenForo_FrontController->run()
#9 {main}
Request State
array(3) {
  ["url"] => string(61) "http://killswitchmc.com/index.php?account-confirmation/resend"
  ["_GET"] => array(1) {
    ["account-confirmation/resend"] => string(0) ""
  }
  ["_POST"] => array(5) {
    ["_xfToken"] => string(8) "********"
    ["_xfConfirm"] => string(1) "1"
    ["_xfRequestUri"] => string(30) "/index.php?account/preferences"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
This is the same error I am getting from every person with over 3 pages of names and emails that tried to send verification emails:
http://puu.sh/hHk1o/880a4a0f1a.png
Can someone please tell me how to fix this? That would be great, thanks.
 

Brogan

XenForo moderator
Staff member
#2
That's just using PHP mail() to send the email which passes off to a sendmail equivalent.

It only tells us whether that accepted the mail for sending.

If it doesn't, this error is logged. Any more specific errors would need to be found in your server's mail log.