Email Troubles

Money

Member
I followed this guide here: http://xenforo.com/community/threads/setting-up-google-as-smtp-server-for-your-xenforo.6180/ and set everything up exactly the same but am getting this error:
Code:
Zend_Mail_Protocol_Exception: 'support@kingcraftmc.com' appears to be a DNS hostname but cannot match against hostname schema for TLD 'com', 'support@kingcraftmc.com' does not appear to be a valid local network name - library/Zend/Mail/Protocol/Abstract.php:145
Generated By: Test, 2 minutes ago
 
#0 /var/www/html/library/Zend/Mail/Protocol/Smtp.php(156): Zend_Mail_Protocol_Abstract->__construct('support@kingcra...', 465)
#1 /var/www/html/library/Zend/Mail/Protocol/Smtp/Auth/Login.php(76): Zend_Mail_Protocol_Smtp->__construct('support@kingcra...', 465, Array)
#2 /var/www/html/library/Zend/Mail/Transport/Smtp.php(198): Zend_Mail_Protocol_Smtp_Auth_Login->__construct('support@kingcra...', 465, Array)
#3 /var/www/html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#4 /var/www/html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#5 /var/www/html/library/XenForo/Mail.php(177): Zend_Mail->send()
#6 /var/www/html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#7 /var/www/html/library/XenForo/Model/UserConfirmation.php(136): XenForo_Mail->send('pcstandel@me.co...', 'Test')
#8 /var/www/html/library/XenForo/ControllerPublic/AccountConfirmation.php(98): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
#9 /var/www/html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_AccountConfirmation->actionResend()
#10 /var/www/html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#11 /var/www/html/index.php(13): XenForo_FrontController->run()
#12 {main}
 
array(3) {
  ["url"] => string(60) "http://kingcraftmc.com/index.php?account-confirmation/resend"
  ["_GET"] => array(1) {
    ["account-confirmation/resend"] => string(0) ""
  }
  ["_POST"] => array(5) {
    ["_xfToken"] => string(8) "********"
    ["_xfConfirm"] => string(1) "1"
    ["_xfRequestUri"] => string(10) "/index.php"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

Jake Bunce

XenForo moderator
Staff member
Are you using an email address for the SMTP host name? That would be incorrect. It should be a valid host such as an IP address or domain name.

When configuring XenForo to use a SMTP server you need to verify all SMTP information with the SMTP host.
 

Money

Member
Are you using an email address for the SMTP host name? That would be incorrect. It should be a valid host such as an IP address or domain name.

When configuring XenForo to use a SMTP server you need to verify all SMTP information with the SMTP host.
Switched it to smtp.gmail.com but now am getting this:
Code:
Zend_Mail_Protocol_Exception: Permission denied - library/Zend/Mail/Protocol/Abstract.php:277
#0 /var/www/html/library/Zend/Mail/Protocol/Smtp.php(167): Zend_Mail_Protocol_Abstract->_connect('ssl://smtp.gmai...')
#1 /var/www/html/library/Zend/Mail/Transport/Smtp.php(199): Zend_Mail_Protocol_Smtp->connect()
#2 /var/www/html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#3 /var/www/html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#4 /var/www/html/library/XenForo/Mail.php(177): Zend_Mail->send()
#5 /var/www/html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#6 /var/www/html/library/XenForo/Model/UserConfirmation.php(136): XenForo_Mail->send('pcstandel@me.co...', 'Test')
#7 /var/www/html/library/XenForo/ControllerPublic/AccountConfirmation.php(98): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
#8 /var/www/html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_AccountConfirmation->actionResend()
#9 /var/www/html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /var/www/html/index.php(13): XenForo_FrontController->run()
#11 {main}
array(3) {
  ["url"] => string(60) "http://kingcraftmc.com/index.php?account-confirmation/resend"
  ["_GET"] => array(1) {
    ["account-confirmation/resend"] => string(0) ""
  }
  ["_POST"] => array(5) {
    ["_xfToken"] => string(8) "********"
    ["_xfConfirm"] => string(1) "1"
    ["_xfRequestUri"] => string(17) "/index.php?forum/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

Jake Bunce

XenForo moderator
Staff member
Switched it to smtp.gmail.com but now am getting this:
Code:
Zend_Mail_Protocol_Exception: Permission denied - library/Zend/Mail/Protocol/Abstract.php:277
#0 /var/www/html/library/Zend/Mail/Protocol/Smtp.php(167): Zend_Mail_Protocol_Abstract->_connect('ssl://smtp.gmai...')
#1 /var/www/html/library/Zend/Mail/Transport/Smtp.php(199): Zend_Mail_Protocol_Smtp->connect()
#2 /var/www/html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#3 /var/www/html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#4 /var/www/html/library/XenForo/Mail.php(177): Zend_Mail->send()
#5 /var/www/html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#6 /var/www/html/library/XenForo/Model/UserConfirmation.php(136): XenForo_Mail->send('pcstandel@me.co...', 'Test')
#7 /var/www/html/library/XenForo/ControllerPublic/AccountConfirmation.php(98): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
#8 /var/www/html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_AccountConfirmation->actionResend()
#9 /var/www/html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /var/www/html/index.php(13): XenForo_FrontController->run()
#11 {main}
array(3) {
  ["url"] => string(60) "http://kingcraftmc.com/index.php?account-confirmation/resend"
  ["_GET"] => array(1) {
    ["account-confirmation/resend"] => string(0) ""
  }
  ["_POST"] => array(5) {
    ["_xfToken"] => string(8) "********"
    ["_xfConfirm"] => string(1) "1"
    ["_xfRequestUri"] => string(17) "/index.php?forum/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
That simply means it couldn't connect to the server using the SMTP info you provided. You need to verify all SMTP information with the SMTP host.
 

Money

Member
That simply means it couldn't connect to the server using the SMTP info you provided. You need to verify all SMTP information with the SMTP host.
How can I be sure? I followed that guide I listed in the original post. These are my settings currently: Screenshot on 2013-04-12 at 16.57.05.png
 
Top