1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Email Error Issue

Discussion in 'Troubleshooting and Problems' started by TechnicalFisherman, Apr 1, 2016.

  1. I run a forum that I recently migrated from a managed VPS on GoDaddy to another hosting plan at GoDaddy. I migrated the forum by copying all directories down from the old server and writing them over an earlier version of the site on the other hosting plan. I then successfully migrated the database. Forum is back up and everything is there and works.

    I attempted to send an email to all users (around 3k) that ended up failing and generating an err_no_response page on chrome, which I think may have been an issue with the browser. However, after that I've started generating email error codes in the server log. They indicate that:

    Zend_Mail_Transport_Exception: Email to XXXX@gmail.com failed: Unable to send mail. - library/Zend/Mail/Transport/Sendmail.php:137

    Stack trace is as follow:

    #0 /home/content/02/8952902/html/technicalfisherman/forum/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
    #1 /home/content/02/8952902/html/technicalfisherman/forum/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #2 /home/content/02/8952902/html/technicalfisherman/forum/library/XenForo/ControllerAdmin/User.php(1029): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
    #3 /home/content/02/8952902/html/technicalfisherman/forum/library/XenForo/ControllerAdmin/User.php(922): XenForo_ControllerAdmin_User->_sendEmail(Array, Array, Object(Zend_Mail_Transport_Sendmail))
    #4 /home/content/02/8952902/html/technicalfisherman/forum/library/XenForo/FrontController.php(347): XenForo_ControllerAdmin_User->actionEmailSend()
    #5 /home/content/02/8952902/html/technicalfisherman/forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #6 /home/content/02/8952902/html/technicalfisherman/forum/admin.php(13): XenForo_FrontController->run()
    #7 {main}

    I searched here for answers, and most seemed t indicate it's a server-side issue, but GoDaddy was of no help. I then tried using my GoDaddy account with the SMTP service on Xenforo and the emails worked but quickly exceeded my daily limit.

    I'd like to get the default email option working and would appreciate any insight/suggestions.

    Many thanks.
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. Tracy Perry

    Tracy Perry Well-Known Member

    Odds are you are also hitting the daily limit using the PHP mail function also. They are going to naturally throttle accounts to make sure that spammers will not use their service - whether it's via SMTP or the PHP sendmail feature.
    To resolve the issue - get a VPS/dedi where you control your own mail (for PHP/MTA) or use a service like MailChimp, SendGrid, Amazon SES, etc (for SMTP connections).

Share This Page