• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Email Confirmation Not Working

#1
I made a Google Apps account too and it's still not working.


#0 /home2/mcterrit/public_html/library/Zend/Mail/Protocol/Smtp.php(167): Zend_Mail_Protocol_Abstract->_connect('ssl://in-v3.mai...')
#1 /home2/mcterrit/public_html/library/Zend/Mail/Transport/Smtp.php(199): Zend_Mail_Protocol_Smtp->connect()
#2 /home2/mcterrit/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#3 /home2/mcterrit/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#4 /home2/mcterrit/public_html/library/XenForo/Mail.php(175): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
#5 /home2/mcterrit/public_html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#6 /home2/mcterrit/public_html/library/XenForo/Model/UserConfirmation.php(136): XenForo_Mail->send('randominecraft7...', 'KingLardcat')
#7 /home2/mcterrit/public_html/library/XenForo/ControllerPublic/AccountConfirmation.php(104): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
#8 /home2/mcterrit/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_AccountConfirmation->actionResend()
#9 /home2/mcterrit/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /home2/mcterrit/public_html/index.php(13): XenForo_FrontController->run()
#11 {main}
Request State
array(3) {
["url"] => string(50) "http://mcterritory.com/account-confirmation/resend"
["_GET"] => array(0) {
}
["_POST"] => array(5) {
["_xfToken"] => string(8) "********"
["_xfConfirm"] => string(1) "1"
["_xfRequestUri"] => string(1) "/"
["_xfNoRedirect"] => string(1) "1"
["_xfResponseType"] => string(4) "json"
}
}
 

Brogan

XenForo moderator
Staff member
#2
You've missed the actual error title but looking at the stack trace it could be a firewall issue preventing outbound connections.
 
#12
You might not have access if you are on a shared hosting account. Check with them and ask them this :

"In order for my forum script to work, I have to "Disable the whm smtp restriction". Is that disabled on my account? If not, can you disable?"

They will let you know.
 
#14
"no, we cannot Disable the whm smtp restriction or anything requiring root or sudo not allowed on shared or cloud"

This is saying that it won't work on your shared server.

Best of luck!
 
#17
Yeah - they might have made some changes since then.

Also, you might have to locally setup an email sender.

Best of luck, that's about the best I can help here

;-)