1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 email confirmation not working...no email...

Discussion in 'Troubleshooting and Problems' started by David Trefry, Jun 28, 2013.

  1. David Trefry

    David Trefry New Member


    I know many people have been down this road already because I tried using the community database to solve it but am having no luck.

    My email transpoprt settins are as follows:

    mail.myhostname.com : port 465
    user name and password

    That email account address is the same for Default Email Address and the outgoing SMTP config above.

    I can register test members and get the message that registration awaits them if they click the link in their email.

    Have I skipped anything?

    The Xen box is running CentOS Linux and I've opened up the firewall to no avail.

    Any help would be much appreciated.

  2. Brogan

    Brogan XenForo Moderator Staff Member

    try switching to the default transport method, rather than SMTP.
  3. David Trefry

    David Trefry New Member

    i tried that. i'll try it again maybe some settings have changed sine the .

    this is just an email client, correct? i can't get out
    on port 25, it's blocked by my isp.

    thanks. stay tuned.

  4. David Trefry

    David Trefry New Member

    what is the default method? do u know what it's settings are?

  5. David Trefry

    David Trefry New Member

    with the default check the destination port is 25. saw it in my router's log. that's why that doesn't work...
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Are you running this from home on a cable/dsl/fibre to the house?
    If so, change your SMTP server to use a different port and then in your router remap inbound port 25 to that new port #.
  7. David Trefry

    David Trefry New Member

    yes from my home via fiber. in addition to my isp i'm using an smtp host which doesn't block any ports. same one i registered my domain name with. i also have the admin email with them.
    do i need to run my own email server?
    they told me, for outgoing email use port 465 ssl. is that the traffic i should remap 25 to?
    i do bave some gaps in my knowledge of this so thanks a lot for a y help.
  8. David Trefry

    David Trefry New Member

    getting close i think. if i use the default, check box with -f, i need to run the sendmail server service because the default checkbox uses the php mail sw, and that uses sendmail. i'll report what i find tomorrow. i need to edit php.ini as well.

    thanks for the help.
  9. David Trefry

    David Trefry New Member


    got the smtp working. dumped sendmail server and switched to postfix server. a good decision for many reasons.

    i had to step through the zend transport code to figure it out. i was using my ( basic board info ) default email address as the bounce address on the email options page, which i now know is not allowed, but was not aware from the error that this was a problem. found it when the code threw the exception.

    php mail still not working. no exceptions but still not receiving. i prefer the php method over smtp and will try to that that working.

Share This Page