Elastisearch results don't seem quite right

sross

Active member
Some users brought this to my attention so am asking here to see what's going wrong. I'll use my photo darkroom forum as an example. When doing a forum specific search in this forum: how to clean lens fungus
There are no results. However if "clean" or "fungus" are searched there are 100's of results. If "how to clean lens fungus" (without the quotes) has no hits should it not default to the closest thing and show results for key words such as "clean" or "fungus"? Stranger yet is that I have the similar threads plus mod installed and this actually does show results where the main search does not. It appears the similar threads mod defaults to any word it can find and displays hits. How do I get my primary search to also function like this? Thanks
 

Mouth

Well-known member
When a user types in search keywords, I would only expect results that include (ALL, default) those words, unless they use the search modifiers to change default behaviour.
I guess what you're asking, is how to change this default beahviour from ALL to OR.
 

sross

Active member
When a user types in search keywords, I would only expect results that include (ALL, default) those words, unless they use the search modifiers to change default behaviour.
I guess what you're asking, is how to change this default beahviour from ALL to OR.
Yeah, but strangely the similar threads mod seems to do this, but I guess he may have coded it to do so where in the elastisearch system settings this is not an option.
 
Top