• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Service issue Editor is losing blank space before links

R

ragtek

Guest
#1
Steps to reproduce:

Copy this post http://xenforo.com/community/threads/foobarbazbazingaaaaaa.31440/#post-388613 to your clipboard and and insert it into the editor (i think this should also work with this bugreport because of the inserted link^^

error.PNG
as you see, the "space" before the link is gone...
It's happening ONLY with links, which are very long and placed because of their lenght in the next line.

Browser: Chrome








Edit: it's whitespace and not blank space, or? (sorry, pls change title if it's wrong)
 

Adam Howard

Well-known member
#3
Looks like another bug in TinyMCE itself...

Does the same thing on the TinyMCE demo... http://www.tinymce.com/tryit/full.php

It also does it with the latest version (3.5.5) of TinyMCE installed in XenForo.

I suspect the fix is going to have to come from the TinyMCE developers. Or a better fix would be to use a different editor in XF. :)
I'll inquire .... How easy is it to apply the newest version of TinyMCE into XenForo?

I assume it is not as simple as overwriting files. :p
 

digitalpoint

Well-known member
#4
It's not too bad if you have some programming background... like the event model changed completely in 3.5, so you need to rewrite anything that used tinyMCE.dom.Event

But truthfully, it's probably not even worth it... I only did it to see if it fixed any of the zillion little issues with the XF editor... and it didn't really change anything as far as that, so...
 

Adam Howard

Well-known member
#5
It's not too bad if you have some programming background... like the event model changed completely in 3.5, so you need to rewrite anything that used tinyMCE.dom.Event

But truthfully, it's probably not even worth it... I only did it to see if it fixed any of the zillion little issues with the XF editor... and it didn't really change anything as far as that, so...
Sir, are a lot more patient than I
 

digitalpoint

Well-known member
#8
I didn't really make the changes as something modular... It's just a small part of my bigger JavaScript class which is for the entire site (all sorts of stuff that has dependencies on other custom things).

It's really not worth it anyway... as I said, I couldn't see a single thing it fixed. I don't plan on redoing it on a XF upgrade... really was just a test to see.