domain issues


Active member
By chance I figured out the problem some people are having logging in. Many users have said they arrive to the site, log in, and immediately are logged out, and told to log in again.

Bottom line: If someone arrives to my site via "", it appears their login doesn't stick because the login defaults to "".

The simple solution is for people to only use "", not "". And knowing that a super majority of our visitors define the term "simple" ... this should solve the problem. But it won't ;-)

Is there an idiot proof solution you can think of?

EDIT: I just noticed that forwards automatically to This seems to solve the problem here.

Can you point me in the right direction as to how to do this for my site?

Thank you


XenForo moderator
Staff member
There are many threads explaining how to do this:[title_only]=1

Not all servers are the same though, so you may need to try a few variations before you find one which works.

Try this thread:

Also in the FAQ:

How can I redirect all traffic to the www or non-www version of my site?
If you are on an Apache server, this can be achieved by editing the .htaccess file. Refer to the discussion thread in the forum for more information.
Note that any custom rewrite rules must come before the XenForo rewrite rules.


Well-known member
The Htaccess Brogan suggested will be the best option here however you can do this in cpanel.

If you have cPanel go to: redirect section on the Domains section.

Type: Permanent (301)
http://(www.)? ** All Public Domains ** / (Leave Blank)
redirects to→
Redirect with or without www. (Tick that bullet point) Click Add

Gene Steinberg

Well-known member
Just a cautionary note: Although cPanel does wonders with redirects, sometimes it flakes out (doesn't work) and you have to delete it and redo it. I've run into that issue more than once.