XF 2.2 Disable - Awaiting approval before being displayed publicly.

Stan

Active member
When any new user signs up and posts messages they get this message: Awaiting approval before being displayed publicly.

But as an admin I can not find where they posts are or how to approve them. Also how do I disable this?

Help
 

FTL

Well-known member
To elaborate on what Brogan said, with XF it's possible to be an admin, but not have any mod permissions, which looks like the case here. You need to be in both user groups. Won't be a problem to add yourself as you're an admin - see the manual.
 

Stan

Active member
Great thanks guys.. I have several other forums, but none of them are moderating all new user posts. Is there an option somewhere I can change how that works other than allowing all registered users to bypass the policy?

Thanks
 

FTL

Well-known member
The account needs to be explicitly promoted to moderator status.

The user groups assign permissions only.
Without moderator status certain functionality won't be available.
Yes, that's what I meant. Apologies, I got confuddled there. The user groups are separate to mod status.
 

jeb35

Well-known member
Great thanks guys.. I have several other forums, but none of them are moderating all new user posts. Is there an option somewhere I can change how that works other than allowing all registered users to bypass the policy?

Thanks
If you only want their first post moderated then you'll need to use usergroup promotions to create a new user group after they post for the first time. Set registered user groups permission of "submit content without approval" to no and then the upgraded usergroup permission of Submit content without approval" to yes This option is under the general permissions under the usergroup.
 
Top