Digital Point Social Bar

Digital Point Social Bar 1.0.2

No permission to download

Mike Edge

Well-known member
Just FYI in case you want to know what it looks like with the brand free license, https://www.digitalpoint.com/ and http://doberman-chat.com/community/ are examples.

Technically there is a way to remove the hover thing on the Social Buttons thing, but it's not a "license", it's a premium membership benefit, although I would never expect anyone to get premium membership for that... it's just a bonus (for example they do that here: http://www.tinhte.vn/ ).


I have premium membership on your site already, so that means it comes with the benefit of the branding free?
 

digitalpoint

Well-known member

Robby

Well-known member
There is something with this addon that blocks the facebook and twitter integration by login.
Doe anyone else has this problem?
Also after a while when i run the cron job i get this:
cron.png
 
Last edited:

BassMan

Well-known member
I also got server error after a cron job runs. But don't know anything more. I've uninstalled it already.
 

Adam Howard

Well-known member
Just FYI in case you want to know what it looks like with the brand free license, https://www.digitalpoint.com/ and http://doberman-chat.com/community/ are examples.

Technically there is a way to remove the hover thing on the Social Buttons thing, but it's not a "license", it's a premium membership benefit, although I would never expect anyone to get premium membership for that... it's just a bonus (for example they do that here: http://www.tinhte.vn/ ).
Thanks again, but I'm not looking to subscribe and lease a service, paying monthly, quarterly, or yearly dues just for 3 buttons.

One of the things I like about XenForo and every add-on on here is you buy it and you own it. Yours would be the 1st "service" and I am not interested in supporting or using such a model.

I will however look to have an alternative to this built and released freely.
 
Last edited:

digitalpoint

Well-known member
There is something with this addon that blocks the facebook and twitter integration by login.
Doe anyone else has this problem?
Also after a while when i run the cron job i get this:
View attachment 74656
What do yu mean it blocks it? We use the Facebook login function where users can login with Facebook without any issues. Are you getting any specific errors?
 

digitalpoint

Well-known member
Thanks again, but I'm not looking to subscribe and lease a service, paying monthly, quarterly, or yearly dues just for 3 buttons.

One of the things I like about XenForo and every add-on on here is you buy it and you own it. Yours would be the 1st "service" and I am not interested in supporting or using such a model.

I will however look to have an alternative to this built and released freely.
There are tons of alternatives already out there... AddThis, ShareThis, etc. I'll probably see about adding a setting so people can use different social buttons without going through the trouble of editing the template.
 

MattW

Well-known member
Just had a play at setting this up, and I'm not getting anything loading in the social bar (apart from the buttons). I've got a list defined with some members in them. I'm seeing this in the error console

upload_2014-5-29_17-44-56.png
 

digitalpoint

Well-known member
There are tons of alternatives already out there... AddThis, ShareThis, etc. I'll probably see about adding a setting so people can use different social buttons without going through the trouble of editing the template.
...and done. :)

upload_2014-5-29_10-3-23.png

Just had a play at setting this up, and I'm not getting anything loading in the social bar (apart from the buttons). I've got a list defined with some members in them. I'm seeing this in the error console

View attachment 74668
What's your URL? Try running the cron task that goes with it manually? Maybe it just hasn't picked them up yet (it only gets the Tweets every 20 minutes by default).
 

digitalpoint

Well-known member

MattW

Well-known member
When trying to update:
Code:
Server Error

Mysqli statement execute error : Duplicate column name 'dp_twitter_slug'

Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
Zend_Db_Adapter_Abstract->query() in DigitalPointSocialBar/Install.php at line 28
DigitalPointSocialBar_Install::installCode()
call_user_func() in XenForo/Model/AddOn.php at line 215
XenForo_Model_AddOn->installAddOnXml() in ConvEss/Model/AddOn.php at line 24
ConvEss_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 236
XenForo_ControllerAdmin_AddOn->actionUpgrade() in XenForo/FrontController.php at line 347
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /home/nginx/domains/mattwservices.co.uk/public/admin.php at line 13
 

MattW

Well-known member
Wrap your db query in the try syntax and it updates OK
PHP:
                $db = XenForo_Application::getDb();
                try
                {
                        $db->query("
                                ALTER TABLE xf_forum
                                        ADD dp_twitter_slug
                                                VARCHAR(25)
                                                CHARACTER SET utf8
                                                COLLATE utf8_general_ci
                                                NOT NULL
                                                DEFAULT ''
                ");
                }
                catch (Zend_Db_Exception $e) {}
 

digitalpoint

Well-known member
Blah...
Wrap your db query in the try syntax and it updates OK
PHP:
                $db = XenForo_Application::getDb();
                try
                {
                        $db->query("
                                ALTER TABLE xf_forum
                                        ADD dp_twitter_slug
                                                VARCHAR(25)
                                                CHARACTER SET utf8
                                                COLLATE utf8_general_ci
                                                NOT NULL
                                                DEFAULT ''
                ");
                }
                catch (Zend_Db_Exception $e) {}
Augh... gross. Installer fixed.
 
Top