• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 deleting a link

AndreaMarucci

Well-known member
#1
In Style and Properties -> Header Navigation I've set the Height of Header Logo to 0. If I set it to 1 or 5 pixels, a rectangle is shown (when there was the logo) with a link to the forum home page.

Schermata 2013-11-26 alle 13.37.35.png

Can someone tell me how can I delete that link so that also the rectangle goes away?
 

Tracy Perry

Well-known member
#2
In Style and Properties -> Header Navigation I've set the Height of Header Logo to 0. If I set it to 1 or 5 pixels, a rectangle is shown (when there was the logo) with a link to the forum home page.

View attachment 61898

Can someone tell me how can I delete that link so that also the rectangle goes away?
In the ACP -> Options -> Basic Board Information do you happen to have the "Link Logo to Home Page URL" checked below the Home Page URL setting? If so, try unchecking that. It may not work as it will default to linking to the forum index.
 

Tracy Perry

Well-known member
#4
Another thing that may work is modifying the logo_block template and removing the link from there.
Code:
<div id="logoBlock">
    <div class="pageWidth">
        <div class="pageContent">
            <xen:include template="ad_header" />
            <xen:hook name="header_logo">
            <div id="logo"><a href="{$logoLink}">
                <span><xen:comment>This span fixes IE vertical positioning</xen:comment></span>
                <img src="@headerLogoPath" alt="{$xenOptions.boardTitle}" />
            </a></div>
            </xen:hook>
            <span class="helper"></span>
        </div>
    </div>
</div>
to

Code:
<div id="logoBlock">
    <div class="pageWidth">
        <div class="pageContent">
            <xen:include template="ad_header" />
            <xen:hook name="header_logo">
            <div id="logo"><xen:comment><a href="{$logoLink}"></xen:comment>
                <span><xen:comment>This span fixes IE vertical positioning</xen:comment></span>
                <img src="@headerLogoPath" alt="{$xenOptions.boardTitle}" />
            </a></div>
            </xen:hook>
            <span class="helper"></span>
        </div>
    </div>
</div>
 

AndreaMarucci

Well-known member
#5
Good one! Changed from this
Code:
<div id="logoBlock">
    <div class="pageWidth">
        <div class="pageContent">
            <xen:include template="ad_header" />
            <xen:hook name="header_logo">
            <div id="logo"><a href="{$logoLink}">
                <span><xen:comment>This span fixes IE vertical positioning</xen:comment></span>
                <img src="@headerLogoPath" alt="{$xenOptions.boardTitle}" />
            </a></div>
            </xen:hook>
            <span class="helper"></span>
        </div>
    </div>
</div>
to this
Code:
<div id="logoBlock">
    <div class="pageWidth">
        <div class="pageContent">
            <xen:include template="ad_header" />
            <xen:hook name="header_logo">
            </xen:hook>
            <span class="helper"></span>
        </div>
    </div>
</div>
and worked!