XF 2.2 Deleting a Banned account Un-deletes deleted posts

Steve Freides

Active member
This is unxpected behavior, maybe a bug:

1. User is banned, all posts appear with the username with a line through it.

2. User's posts are all manually deleted, but the hidden-from-public-view kind, not the permanently-delete kind.

3. In ACP, user account is deleted.

4. Users posts now appear with Deleted Member <nnnnn> but have also reappeared as publicly viewable again - this seems unexpected and I consider it bug.

Comments?

Thanks.

-S-
 

Your Ski Advisor

Active member
We tend not to delete banned users posts, unless they are in violation of our T&C because it can disrupt the flow of a thread.

We also do not used "Banned". We were served papers by a banned member that by having banned under their name was hurting them in a job search (or something). We chose not to deal with it and used something more creative, in our case being a ski forum, "Pass Pulled" which is enough to not have an issue. We also use "Inactive" for people who want their account closed, we do not delete accounts, period.
 

Steve Freides

Active member
@Your Ski Advisor, no disrespect intended - it's interesting to hear what you do and why - but my first concern here is to know if what I'm seeing is a bug or an expected behavior and, if the latter, to understand why it works the way it does.

Thanks.

-S-
 

Mr Lucky

Well-known member
Comments?
This doesn't happen for me (just did a test). You are correct that would not be expected behaviour, but I cannot reproduce the issue, for me it all works as expected
We also do not used "Banned". We were served papers by a banned member that by having banned under their name was hurting them in a job search (or something)

In that case why put banned under their name? Default is to not show anyone apart from mods/admin that someone is banned.

[sorry for OT, it would be best for new thread on Your Ski Advisor problem)
 

Steve Freides

Active member
Thank you for the replies, everyone. I am not sure why this happened but it's interesting that it happened, and we can repeat the behavior here. We do have a number of add-ons installed, so perhaps that's why, but at this point, it will be a project for another day.

Thanks again.

-S-
 
Top