• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Custom BB Codes

Custom BB Codes 1

No permission to download

Edrondol

Well-known member
#2
Is there an easy way to add these to the Help screen? Right now I think you have to:

  1. ACP -> Appearance -> Phrases
  2. Create phrase "bb_code_help_####_title" (ex. bb_code_help_quote_title). In this one you'd put (using the example and "{" instead of "[") {QUOTE} - Quoted Text
  3. Create phrase "bb_code_help_####_desc" (ex. bb_code_help_quote_desc). In this one you'd put the description of what the BB Code does.
  4. Create phrase "bb_code_help_####_example" (ex. bb_code_help_quote_example). In this one you'd put {QUOTE}Quoted text{/QUOTE}.
So each one of these has a 3 step process. Correct?
 

Brogan

XenForo moderator
Staff member
#3
After importing the .xml, assuming you have made the necessary template edit as part of installing the main BBCM add-on, they will show automatically.

There's nothing more to do other than import the .xml.
 

Edrondol

Well-known member
#4
Well okay then. Thanks, man. I guess I needed to refresh.

Mine, however, did not show. Is there a limit?

Never mind. I reverted the template edit on my last upgrade and didn't add it back. All is well and nice job!
 

Jeremy

Well-known member
#7
Thanks, I've updated it to point directly to your resource.

BTW, the attachments on your resource are from the original thread - you need to upload new images if you want them to display on the resource and use the lightbox.
It was a quick repost. I missed the attachment upload section. Is it done via a resource blog post?
 

Jeremy

Well-known member
#9
Ahhh, I see this now. I will get to that at some point this weekend. I have a project due on sunday that I haven't started and work in a few hours.
 

RobParker

Well-known member
#10
It would be really useful if somewhere we could keep track of the custom bbcodes which work with KK's BBCode Manager.

I'm not sure of the best way to do that without forcing people to add it into the title of their BBCode in the RM...
 

Beanjam

Active member
#11
When using the PRE code, if I edit the post afterwards then TinyMCE removes all the extra padding spaces I put in. Is there anyway to preserve these spaces during edits?

Also when adding tables I was getting a lot of line breaks added above the table. To remove the line breaks ensure "Stop conversion of line breaks to HTML line breaks." is checked for the Table BBcode.
 

XenStyle

Active member
#12
Also when adding tables I was getting a lot of line breaks added above the table. To remove the line breaks ensure "Stop conversion of line breaks to HTML line breaks." is checked for the Table BBcode.
I am having this issue, and it is checked for all of the table bbcodes. But I still have massive line breaks above the table - any fix to this or am I doing something wrong?

I have tried different checked and unchecked combinations - nothing works.
 

XenStyle

Active member
#13
Two months later, and I still can't figure this out.... Seems that everytime I enter a new table row, it will create another line break

Anyone?
 

Brogan

XenForo moderator
Staff member
#14
Try entering the table code as one unbroken string, like so:
Code:
[table][tr1][th]Season[/th][th]Overtakes[/th][/tr1][tr2][td2]1982[/td2][td2]638[/td2][/tr2][tr1][td2]1983[/td2][td2]607[/td2][/tr1][tr2][td2]1984[/td2][td2]666[/td2][/tr2][tr1][td2]1985[/td2][td2]657[/td2][/tr1][tr2][td2]1986[/td2][td2]581[/td2][/tr2][tr1][td2]1987[/td2][td2]558[/td2][/tr1][tr2][td2]1988[/td2][td2]493[/td2][/tr2][tr1][td2]1989[/td2][td2]547[/td2][/tr1][tr2][td2]1990[/td2][td2]494[/td2][/tr2][tr1][td2]1991[/td2][td2]495[/td2][/tr1][tr2][td2]1992[/td2][td2]406[/td2][/tr2][tr1][td2]1993[/td2][td2]392[/td2][/tr1][tr2][td2]1994[/td2][td2]289[/td2][/tr2][tr1][td2]1995[/td2][td2]297[/td2][/tr1][tr2][td2]1996[/td2][td2]186[/td2][/tr2][tr1][td2]1997[/td2][td2]285[/td2][/tr1][tr2][td2]1998[/td2][td2]207[/td2][/tr2][tr1][td2]1999[/td2][td2]260[/td2][/tr1][tr2][td2]2000[/td2][td2]279[/td2][/tr2][tr1][td2]2001[/td2][td2]230[/td2][/tr1][tr2][td2]2002[/td2][td2]235[/td2][/tr2][tr1][td2]2003[/td2][td2]303[/td2][/tr1][tr2][td2]2004[/td2][td2]277[/td2][/tr2][tr1][td2]2005[/td2][td2]204[/td2][/tr1][tr2][td2]2006[/td2][td2]287[/td2][/tr2][tr1][td2]2007[/td2][td2]270[/td2][/tr1][tr2][td2]2008[/td2][td2]260[/td2][/tr2][tr1][td2]2009[/td2][td2]244[/td2][/tr1][tr2][td2]2010[/td2][td2]547[/td2][/tr2][tr1][td2]2011[/td2][td2]1152[/td2][/tr1][tr2][td2]2012[/td2][td2]1143[/td2][/tr2][tr1][td2]2013[/td2][td2]276+[/td2][/tr1][/table]
If you have any line breaks/carriage returns/new rows in the code it will do that.
 

XenStyle

Active member
#15
Try entering the table code as one unbroken string, like so:
Code:
[table][tr1][th]Season[/th][th]Overtakes[/th][/tr1][tr2][td2]1982[/td2][td2]638[/td2][/tr2][tr1][td2]1983[/td2][td2]607[/td2][/tr1][tr2][td2]1984[/td2][td2]666[/td2][/tr2][tr1][td2]1985[/td2][td2]657[/td2][/tr1][tr2][td2]1986[/td2][td2]581[/td2][/tr2][tr1][td2]1987[/td2][td2]558[/td2][/tr1][tr2][td2]1988[/td2][td2]493[/td2][/tr2][tr1][td2]1989[/td2][td2]547[/td2][/tr1][tr2][td2]1990[/td2][td2]494[/td2][/tr2][tr1][td2]1991[/td2][td2]495[/td2][/tr1][tr2][td2]1992[/td2][td2]406[/td2][/tr2][tr1][td2]1993[/td2][td2]392[/td2][/tr1][tr2][td2]1994[/td2][td2]289[/td2][/tr2][tr1][td2]1995[/td2][td2]297[/td2][/tr1][tr2][td2]1996[/td2][td2]186[/td2][/tr2][tr1][td2]1997[/td2][td2]285[/td2][/tr1][tr2][td2]1998[/td2][td2]207[/td2][/tr2][tr1][td2]1999[/td2][td2]260[/td2][/tr1][tr2][td2]2000[/td2][td2]279[/td2][/tr2][tr1][td2]2001[/td2][td2]230[/td2][/tr1][tr2][td2]2002[/td2][td2]235[/td2][/tr2][tr1][td2]2003[/td2][td2]303[/td2][/tr1][tr2][td2]2004[/td2][td2]277[/td2][/tr2][tr1][td2]2005[/td2][td2]204[/td2][/tr1][tr2][td2]2006[/td2][td2]287[/td2][/tr2][tr1][td2]2007[/td2][td2]270[/td2][/tr1][tr2][td2]2008[/td2][td2]260[/td2][/tr2][tr1][td2]2009[/td2][td2]244[/td2][/tr1][tr2][td2]2010[/td2][td2]547[/td2][/tr2][tr1][td2]2011[/td2][td2]1152[/td2][/tr1][tr2][td2]2012[/td2][td2]1143[/td2][/tr2][tr1][td2]2013[/td2][td2]276+[/td2][/tr1][/table]
If you have any line breaks/carriage returns/new rows in the code it will do that.
Sure enough; that fixed the problem, thank you!

Is there any way to get around this? I use this for a public wiki, and as you can imagine, this will easily confuse some people :p
 

XenStyle

Active member
#16
Anyone have any ideas on how to remove the line breaks without having it unbroken? I use this for our wiki, and members are getting too confused with the unbroken string.

There has to be a way.