• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Criteria User Titles 1.1.1

No permission to download
Very powerful user titles!

Liam W

Well-known member
#1
Liam W submitted a new resource:

Criteria User Titles - Very powerful user titles!

This addon allows you to create user titles using the XenForo user criteria system, as used by the promotion, trophy and notices systems.

With this addon you can create powerful user titles for your users.

You setup the user titles and the criteria in the AdminCP, and the addon does the rest.

If you have a user which would match multiple titles, the title with the greatest priority will be used.

Want a default user title? No worries! Create a user title with the lowest priority and have no...
Read more about this resource...
 

AndreaMarucci

Well-known member
#4
Something don't work. Copied the folder, tried to install and
Code:
Fatal error: Class 'LiamW_Shared_DatabaseSchema_Abstract' not found in /xxxxxx/library/LiamW/CriteriaTitles/DatabaseSchema/CriteriaTitles.php on line 4
 

Liam W

Well-known member
#5
Something don't work. Copied the folder, tried to install and
Code:
Fatal error: Class 'LiamW_Shared_DatabaseSchema_Abstract' not found in /xxxxxx/library/LiamW/CriteriaTitles/DatabaseSchema/CriteriaTitles.php on line 4
Whoops, yet again I forgot to include the shared classes.
 

Martok

Well-known member
#16
@Liam W I get a blank page when I try installing this add-on - once I click on install and choose the XML file, there is no Processing... page with rebuilding of templates etc as usual, just a blank page.

Checking the server error log and I get this:

Code:
Server Error Log
Error Info
ErrorException: Fatal Error: Class 'LiamW_Shared_DatabaseSchema_Abstract' not found - library/LiamW/CriteriaTitles/DatabaseSchema/CriteriaTitles.php:4
Generated By: Martok, A moment ago
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Request State
array(3) {
  ["url"] => string(60) "http://www.mysite.com/admin.php?add-ons/install"
  ["_GET"] => array(1) {
    ["add-ons/install"] => string(0) ""
  }
  ["_POST"] => array(3) {
    ["server_file"] => string(0) ""
    ["_xfConfirm"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
  }
}

Files have been uploaded several times just to be sure and I've re-downloaded the add-on again too.
 

Liam W

Well-known member
#17
@Martok just updated it, download again :)

I tried to do this the other day at school, but I couldn't upload files over the proxy I was using (and I forgot to do it when I got home).
 

Martok

Well-known member
#20
I've set up the criteria and it's not displaying the user titles. I've tried running the user group promotion cron, I've rebuilt the user group promotions cache and I've even re-installed the master data but they are still not showing. They should at least show for me, being active. I have checked that the criteria is correct and I'm using the criteria "User is a member of any of the selected user groups" and chosen a user group that I am a member of.

*EDIT* I've just checked and they are displaying - in the space where custom user titles go. I didn't spot it as I have a custom user title but have seen it on another user.

upload_2014-5-26_19-50-36.png
The criteria user title here is "Level 3"

So, the criteria user titles don't display if you are using a custom user title, there is no styling and they are appearing above the user group banners instead of below as shown on your website.