• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Contact Us - Unable To Receive Email From Members, Guests,...

Ji2myTran

Active member
#1
Hi Guys,

I was tried to use gmail, hotmail (...@live.com) and even my email using the current domain but i didn't receive any emails send to contact us email that i was left in the Basic Board Information after making a test for admin, member and guest groups.

I have a look on the Server Error Logs (Xenforo Admin) and found some error like this:

Error Info:

Zend_Mail_Protocol_Exception: Your FROM must be as the account you have authenticated with. - library/Zend/Mail/Protocol/Abstract.php:431
Generated By: Unknown Account, yeterday, at 20:51

Stack Trace:

#0 /home/lamourhd/public_html/library/Zend/Mail/Protocol/Smtp.php(324): Zend_Mail_Protocol_Abstract->_expect(250, 600)
#1 /home/lamourhd/public_html/library/Zend/Mail/Transport/Smtp.php(215): Zend_Mail_Protocol_Smtp->data('Subject: =?utf-...')
#2 /home/lamourhd/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#3 /home/lamourhd/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#4 /home/lamourhd/public_html/library/XenForo/Mail.php(177): Zend_Mail->send()
#5 /home/lamourhd/public_html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#6 /home/lamourhd/public_html/library/XenForo/ControllerPublic/Misc.php(197): XenForo_Mail->send('ji2mytran@live....', '', Array, 'ji2mytran@live....', 'Tran Phi Truong')
#7 /home/lamourhd/public_html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Misc->actionContact()
#8 /home/lamourhd/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#9 /home/lamourhd/public_html/index.php(13): XenForo_FrontController->run()
#10 {main}

Request State:

array(3) {
["url"] => string(41) "http://lamourhd.vn/index.php?misc/contact"
["_GET"] => array(1) {
["misc/contact"] => string(0) ""
}
["_POST"] => array(10) {
["_guestUsername"] => string(15) "Tran Phi Truong"
["email"] => string(18) "ji2mytran@live.com"
["captcha_question_answer"] => string(6) "HA NOI"
["captcha_question_hash"] => string(40) "045a655d34dd6bf8f7275f72a41aa9fd0e86a839"
["subject"] => string(17) "Lien he quang cao"
["message"] => string(82) "test Lien he quang cao

Xem thêm tại Thế Giới HD Media: http://lamouhd.vn"
["_xfToken"] => string(0) ""
["_xfRequestUri"] => string(17) "/index.php?forum/"
["_xfNoRedirect"] => string(1) "1"
["_xfResponseType"] => string(4) "json"
}
}
You also can check out the below screenshots for more details.

contact_us_error1.jpg contact_us_error2.jpg

Any ideals how to fix this?

Thanks! :(
 

Ji2myTran

Active member
#3
Hi Tracy Perry,

Yes, the SMTP setting was correct. I'm able to send out the emails. However, unable to receive email as well. Is it because of email configuration from Hosting provider?

Thanks!
 

MattW

Well-known member
#4
I've seen that error message before when I tried setting my e-mail up with Amazon as the SMTP provider
 
#6
Hi Guys,
I have tried to set up and enable something in my Cpanel admin, then i'm able to send and receive email from the others now. However, when i tried to send any messages using contact form by using any member groups, i'm still unable to receive any emails that send to me.
Anyone plz help on this?
Thanks! :(
 

Tracy Perry

Well-known member
#7
Hi Guys,
I have tried to set up and enable something in my Cpanel admin, then i'm able to send and receive email from the others now. However, when i tried to send any messages using contact form by using any member groups, i'm still unable to receive any emails that send to me.
Anyone plz help on this?
Thanks! :(
Does cPanel make all the necessary DNS entries (reverse DNS, etc). Also, have you set up your MX records?
 
#8
Hi,

For MX Entry in Cpanel, i have set the Email Routing with the selection: Automatically Detect Configuration for Local Mail Exchanger

In the Domain Control Panel DNS: all names and values are correctly set up based on my domain and server setting as well. Which is why i'm able to send and receive emails from the other now.

However, the contact form is still not working, the error is still the same as in my first post, anyone know about this error please? :(

Thanks!
 

Tracy Perry

Well-known member
#9
Hi,

For MX Entry in Cpanel, i have set the Email Routing with the selection: Automatically Detect Configuration for Local Mail Exchanger

In the Domain Control Panel DNS: all names and values are correctly set up based on my domain and server setting as well. Which is why i'm able to send and receive emails from the other now.

However, the contact form is still not working, the error is still the same as in my first post, anyone know about this error please? :(

Thanks!
Have you modified the template(s) for it by chance? If so, try reverting them... other than that, I'm at a loss since I've never had that error before.
 
#10
Hi Tracy,

Do you know what are the templates tat i need to revert them, though i haven't made any changes yet regarding this in any templates. however, i'm still wanna give a try.

Thanks! ;)
 

Tracy Perry

Well-known member
#11
Hi Tracy,

Do you know what are the templates tat i need to revert them, though i haven't made any changes yet regarding this in any templates. however, i'm still wanna give a try.

Thanks! ;)
The contact template is called contact. Check it in your ACP templates and see if it needs to be reverted (before reverting it copy your existing into your clipboard and save it to an editor just in case reverting it doesn't solve it).
 
#12
Unfortunately, there are no any changes that name in the contact template, which is why i couldn't revert it. I guess this is due to SMTP authentication, but don't know how to fix in in Cpanel, or what i have to ask hosting provider since i'm still unable to send and receive all emails, except for the contact form... Sad!!! :(
 

Tracy Perry

Well-known member
#13
Unfortunately, there are no any changes that name in the contact template, which is why i couldn't revert it. I guess this is due to SMTP authentication, but don't know how to fix in in Cpanel, or what i have to ask hosting provider since i'm still unable to send and receive all emails, except for the contact form... Sad!!! :(
OK... just to make sure I have it straight
Your forum IS able to send notifications for new replies, alerts and the like.
Your forum IS able to send the registration link message to new users.
Your forum IS NOT able to send a "contact us" message to your defined email address.

Does the email address in your ACP Email settings actually exist as a user?
 

Tracy Perry

Well-known member
#14
Also, forgot to ask.
I'm assuming you are trying to send this from your forum account. Does the email address you set up for your user actually exist?
 
#15
@ Tracy:

Your forum IS able to send notifications for new replies, alerts and the like.
Your forum IS able to send the registration link message to new users.
Your forum IS NOT able to send a "contact us" message to your defined email address.
Yes, you are correct.

For the email that i set in "Contact Email address" of basic board information is the email of hosting provider that i'm using now. I even tried to use the same one that i set in SMTP for user registration or used the other emails that i was created from the hosting provider and other email service provider such as gmail, live.com,... but all of them are not receive any email after i tried to submit the contact form... Hic!! :cry:
 
#16
Because of this error, i have just purchased for a new hosting from Godaddy and tried to set up everything with a new forum for testing purpose. But still, I'm able to send and receive email from the email hosting (emails that i created from the domain i bought and set up with Daddy) but the contact form is not working... Anyone know if i have made anything wrong or what kind of permission that i need to set in Xenforo setting to make it work please? :cry::cry::cry::cry::cry:

Thank you!
 

Tracy Perry

Well-known member
#17
If anyone else wants to help out, feel free to. For reasons that I relayed in a conversation to the OP, I will no longer be attempting to help him out.