1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Changing Landing Page

Discussion in 'XenForo Questions and Support' started by The Dark Wizard, Feb 16, 2014.

  1. The Dark Wizard

    The Dark Wizard Well-Known Member

    I have xF installed in root, so you see the board when you go to www.mydomain.com

    I made a page the new index, so the board goes to www.mydomain.com/forums as expected.

    However for somereason the index URL broke, before it would display the contents of the page I selected at www.mydomain.com

    However now that I updated to the latest xF and rebuild my dev site, now visting mydomain.com shows the entire URL for the page.

    I don't remember how I had gotten it before the Board reset for our dev site. Any ideas? I know it didn't require addons and it was all done with xF.
     
  2. The Dark Wizard

    The Dark Wizard Well-Known Member

    This is really driving us up the way.

    I don't know how I had done it before, was it just a fluke? Reading around xF shows that it shouldn't be possible unless that was dated information but for the longest time we had a page set as the index, while the URL stayed the same, IE. www.mydomain.com

    No www.mydomain.com/pages/insertpagenamehere

    The best I can do it seems is change the page's url with the route filter.
     
  3. The Dark Wizard

    The Dark Wizard Well-Known Member

    All fixed out.

    Apparently adding the index as pages/mypagename with an ending /

    gives me the result I want.

    @Mike is this intentional?
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    Yes, you need the trailing slash. This is shown within the description.
     
  5. The Dark Wizard

    The Dark Wizard Well-Known Member

    Didn't seem obvious to me at the start that I was missing it.

    Sorry :(.
     

Share This Page