1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Censorship Per Node [Deleted]

Discussion in 'Add-on Releases' started by Brivium, Jan 23, 2013.

Thread Status:
Not open for further replies.
  1. Brivium

    Brivium Well-Known Member

    ******* submitted a new resource:

    Censorship Per Node (version 1.0.0) - This addon enables you to disable the censorship for certain forums through the admincp. More: htt

    Read more about this resource...
     
  2. Jeff Fuqua

    Jeff Fuqua Well-Known Member

    When I go into the node with this activated, I still get the censored words until I refresh the page or go to another page within the node. This isn't a problem but just wanted to let you know in case it is not intended.

    Funny how everyone is trying to out cuss the other since they can now do it in one forum area. ;)
     
  3. DFI

    DFI Active Member

    Can you please suggest why i am getting this error

     
  4. giorgino

    giorgino Well-Known Member

    Idem +1
     
  5. giorgino

    giorgino Well-Known Member

    *******, I'm very glad to see you back to develop some great add-on.
    Can you spend a little time to solve the bug? I really love this addon :)

    Thank you
     
  6. tyteen4a03

    tyteen4a03 Well-Known Member

    Hopefully this works with 1.2?

    EDIT: Nope, doesn't. @******* , can you look into this error:

    Server Error

    Undefined index: forum

    XenForo_Application::handlePhpError() in *******/ForumCensorship/ControllerPublic/Forum.php at line 8
    *******_ForumCensorship_ControllerPublic_Forum->actionIndex() in Waindigo/AlPag/ControllerPublic/Forum.php at line 45
    Waindigo_AlPag_ControllerPublic_Forum->actionIndex() in WidgetFramework/XenForo/ControllerPublic/Forum.php at line 13
    WidgetFramework_XenForo_ControllerPublic_Forum->actionIndex() in XenTrCom/WhoHasVisited/Controller/Public.php at line 4
    XenTrCom_WhoHasVisited_Controller_Public->actionIndex() in EWRporta/ControllerPublic/Forum.php at line 9
    EWRporta_ControllerPublic_Forum->actionIndex() in XenForo/FrontController.php at line 337
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/things/public_html/forums/index.php at line 13
     
    Last edited: Sep 29, 2013
    Brivium likes this.
  7. Brivium

    Brivium Well-Known Member

    Hi

    We will upgrade and release soon.

    Thanks for your report.

    Regards,
     
  8. Brivium

    Brivium Well-Known Member

    tyteen4a03 likes this.
  9. RoldanLT

    RoldanLT Well-Known Member

  10. Abracadaniel

    Abracadaniel Member

    Hi @*******,
    Sometimes if you jump to message from last activity page, messages being censored until you press Ctrl+Shift+R (Firefox). They also appear uncensored at last activity page.
    Xenforo 1.1.1

    Could this be solved by upgrading to Xenforo 1.2?
     
  11. Case

    Case Active Member

    Just noticed a bug with this on 1.3

    I have it setup so that one forum is excluded from censoring.

    I've noticed in other forums though that censored words can still appear in the thread title.
     
    Brivium likes this.
  12. Warchamp7

    Warchamp7 Active Member

    This occurs on 1.2.4 as well, I think it is a general issue
     
  13. Brivium

    Brivium Well-Known Member

    @Case

    We checked your report but our addon still works good on XenForo 1.3.x

    Regards,
     
  14. Warchamp7

    Warchamp7 Active Member

    And what about me having the same problem?
     
  15. Brivium

    Brivium Well-Known Member

    @Case @Warchamp7 Thanks for your report, we found issue. We will upgrade to fix this bug soon.

    Regards,
     
    Case and Warchamp7 like this.
  16. Brivium

    Brivium Well-Known Member

  17. giorgino

    giorgino Well-Known Member

    on 1.2.5

    ErrorException: Fatal Error: Class '*******_*******Library_EventListeners' not found -library/*******/ForumCensorship/Listener.php:3

    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}

    array(3) {
    ["url"] => string(40) "http://immobilio.it/index.php?liveupdate"
    ["_GET"] => array(1) {
    ["liveupdate"] => string(0) ""
    }
    ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(52) "/threads/nome-nuova-agenzia-immobiliare.30567/page-2"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
    }
    }
     
  18. Brivium

    Brivium Well-Known Member

  19. Brivium

    Brivium Well-Known Member

    @giorgino Sorry about our wrong file mistake. Please try to download and re-upgrade.

    Regards,
     
    giorgino likes this.
  20. Rho Delta

    Rho Delta Well-Known Member

    This should be in the core, great idea.
     
Thread Status:
Not open for further replies.

Share This Page