1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't submit new posts + Home button missing

Discussion in 'Troubleshooting and Problems' started by andret, May 12, 2011.

  1. andret

    andret Member

    Couple of days ago, my xenforo at ourforums.net/community stopped letting people submit any kind of posts, exept status updates. I run suPHP, tried with suEXEC, and without. Requirement script say I should have all needed stuff. At the same time as the board started breaking, the home button went missing, if that helps indicating where the fault is.

    No error shows up in the in apache log, or Xenforos log. (Have not found out where cpanel hides the php log yet though.)

    When submitting a new post, the layout on the site breaks, and the nothing.

    I also tried reinstalling the board with no luck.

    Is there any thing more I can do to fix this?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Did you do anything prior to the problems starting?

    Do you have any add-ons installed?

    Is it a default style or have you edited any templates?

    Have you added any additional JavaScript?

    You could try uploading all files from the upgrade package once more to see if that resolves the problems.
  3. andret

    andret Member

    I have migrated the server from plesk to cpanel, but Xenforo worked for several days before crashing.

    I have reuploaded several times already.

    I used a custom theme, but the first I tried was changing to the default one. I have disabled all mods as well, not solving anything.

    I have recompiled apache and php several times, not helping a thing. Have tried with fastcgi, dso and cgi, no help.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    When you say the layout breaks, do you mean the CSS isn't being loaded?

    The Home tab is an ACP setting in Options -> Basic Board Information: Home Page URL
  5. andret

    andret Member

    The home url is set, so it should show up.

    Parts of the layout breaks, a white bar shows just below the admin bar, and the footer disapears, and width atributes breaks as well. Colours are still there though. My initial guess was jquery not working as it should, but that should not make the post not be submitted.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    So it worked prior to migrating to cpanel and then for a few days after.

    Did you make any changes to the server configuration or install any new add-ons immediately prior to everything breaking?

    We need to try and identify the reason for the problem, it's very rare that issues such as this happen spontaneously, unless it's related to corruption and you said you've already reuploaded the files and tried a default style.
  7. andret

    andret Member

    I compiled apache a couple of times, had to get used to easyapache and its outdateishnes. I have also used memcached, but removed it at some point after the migration.

    I tried to completely uninstall widget framework now, instead of just disabling it and that gave me this error:
    call_user_func() expects parameter 1 to be a valid callback, class 'WidgetFramework_Installer' not found
    call_user_func() in XenForo/DataWriter/AddOn.php at line 148
    XenForo_DataWriter_AddOn->_postDelete() in XenForo/DataWriter.php at line 1645
    XenForo_DataWriter->delete() in XenForo/ControllerAdmin/AddOn.php at line 114
    XenForo_ControllerAdmin_AddOn->actionDelete() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /home/oufo/public_html/community/admin.php at line 13
    Could a disabled plugin interfere with the board?

    Edit: Same happened when trying to uninstall xenporta as well
  8. Lawrence

    Lawrence Well-Known Member

    You can add this to your config.php (just under the <?php line) file to disable all listeners:

    $config['enableListeners'] = false;

    Did that make a difference?
  9. andret

    andret Member

    Sorry, Lawrence, it did not work :(

    I updated the above plugins, and un-installed them. Did not help the situation.
  10. Lawrence

    Lawrence Well-Known Member

    I just looked at your page source and noticed the link for the Home Tab is commented out:

    <!-- home -->
            <!--  -->
                <!-- <li class="navTab home PopupClosed"><a href="http://ourforums.net/" class="navLink">Home</a></li> -->
            <!--  -->
    I'm not sure if an add-on did this, or it was manually done.
  11. James

    James Well-Known Member

    Seems strange to have so many sets of comments above and below it too... maybe it was an add-on.

    Check your navigation template for the code.
  12. andret

    andret Member

    We managed to fix the problems. It was the combination of Varnish and Cloudflare not completly understanding each other. making Cloudflare cache something wrong.

    Still do not understand why the default theme was not updated though, Those comments I put in there during beta 6 or something.

Share This Page