XF 2.1 Can't get mailgun relay working...

I was using bd mails until I upgraded pas XF1. Now I can't get mailgun working with SMTP relay settings. It seems to auth fine to mailgun, but I get this error. I'm not even sure if it's an error. I don't see any logs on the mailgun side.

I'm using 587 / TLS. If I use any other port or protocol, I get a "connection rejected" error, so I assume this is right. I know my credentials are right as well, but if I use the wrong credentials, I still get the exact message as below. Maybe a setup on the mailgun side? I feel like this should be a lot easier to set up.

Use this tool to diagnose outbound mail transport issues.
Errors were encountered while trying to send the email.
Expand log details
++ Starting Swift_SmtpTransport
<< 220-server1.xxxx.com ESMTP Exim 4.91 #1 Sun, 05 May 2019 19:53:41 +0000
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.

> EHLO xxxx.com

<< 250-server1.xxxx.com Hello xxxx.com[192.64.118.111]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP

> STARTTLS

<< 220 TLS go ahead
 
I can't understand what I can do differently. My credentials are correct. My SMTP settings are correct as far as I know.

Sending via API (with bdmails) worked great for the past few years.
 

Sim

Well-known member
The key message is this one: "220-We do not authorize the use of this system to transport unsolicited, and/or bulk e-mail"

Your emails are being treated as spam.

What is server1.xxxx.com? Is that the destination mail server?
 
Mailgun isn't even showing the failure in the logs - which is weird. I feel like it would at least take the credentials and log in, then fail. Or something. Man, this sucks. Wasting my whole Sunday trying to make this work. I thought this would be a pretty straight forward upgrade =( No going back now.
 
FIXED! Stupid CPanel security. I guess this was enabled, but it never mattered since I was using the mailgun API to send mail before.

smtp_restrictions.png
SMTP Restrictions

This feature prevents users from bypassing the mail server to send mail, a common practice used by spammers.
It will allow only the MTA, mailman, and root to connect to remote SMTP servers.
This control is also adjustable in Tweak Settings.
This setting has been updated.
The SMTP restriction is disabled.
Enable
 
  • Like
Reactions: Sim
Top