• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Can't find forum unless domain includes INDEX.PHP in url

#1
Can anybody tell me why my forum needs to include index.php in the url? Some of the browsers (i.e. Chrome) will not direct you to the site automatically. Other browsers (i.e. Firefox) add the index.php to the url but do open to the forum. I'm almost certain this began after my last upgraded. Did I do something wrong in the upgrade?

To illustrate, if I enter http://www.theplugyourconnect.com in Chrome, it will take me to a search results page and I have to click on my forum to open it. If, however, I enter http://www.theplugyourconnect.com/index.php it will open to my forum.
 

borbole

Well-known member
#2
Can anybody tell me why my forum needs to include index.php in the url? Some of the browsers (i.e. Chrome) will not direct you to the site automatically. Other browsers (i.e. Firefox) add the index.php to the url but do open to the forum. I'm almost certain this began after my last upgraded. Did I do something wrong in the upgrade?

To illustrate, if I enter http://www.theplugyourconnect.com in Chrome, it will take me to a search results page and I have to click on my forum to open it. If, however, I enter http://www.theplugyourconnect.com/index.php it will open to my forum.
You can remove that if you want.

http://xenforo.com/help/friendly-urls/
 

Martok

Well-known member
#3
To illustrate, if I enter http://www.theplugyourconnect.com in Chrome, it will take me to a search results page and I have to click on my forum to open it. If, however, I enter http://www.theplugyourconnect.com/index.php it will open to my forum.
I've just tried this in Chrome and http://www.theplugyourconnect.com takes me to your forums (not a search result page), though the URL it shows is http://www.theplugyourconnect.com/index.php when I arrive.

If you don't want index.php you will need to enable full friendly URLs in the ACP, though see the details below to make sure your server supports this.

https://xenforo.com/help/friendly-urls/