1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't figure out this server issue...

Discussion in 'Server Configuration and Hosting' started by Jaxel, Mar 29, 2013.

  1. Jaxel

    Jaxel Well-Known Member

    Okay... I have two websites...


    They are located at:

    They have favicon.ico here:
    http://smash4u.net/favicon.ico (/public_html/smash/favicon.ico)
    http://yokappakappa.com/favicon.ico (/public_html/kappa/favicon.ico)

    The problem is the kappa icon shows the smash icon, instead of it's own. If I delete the smash icon, the kappa icon will start showing up, but the moment I reupload the smash icon, the kappa icon will get replaced again. What could be causing this issue?
  2. Steve F

    Steve F Well-Known Member

    Looking at the direct links the favicon show the same on both urls.

    <link rel="shortcut icon" href="http://www.yoursite.com/favicon.ico?v=2" />
    You can use that in PAGE_CONTAINER to force refresh on the favicon.
  3. Jaxel

    Jaxel Well-Known Member

    Not really pertinent to the issue... especially since there is no favicon shortcut in the page_container... it takes the file in the root.
  4. Fufu

    Fufu Well-Known Member

    a shot in the dark... did you accidentally drop the smash 'favicon.ico' in the 'public_html' folder?
  5. Jaxel

    Jaxel Well-Known Member

    Nope... its not just favicon.ico... its actually ANY image and html file (doesn't seem to affect php files, which is why the websites themselves run fine). If the image/html file exists in /public_html/smash, it seems to overwrite /public_html/kappa. The moment I delete the file from smash, it works properly in kappa, but then smash is broken.

    Based on this, I thought it was an htaccess issue... so I deleted the .htaccess in /public_html, /smash and /kappa (even though the .htaccess files in /smash and /kappa shouldn't affect one another)... and yet, the issue remained.
  6. Fufu

    Fufu Well-Known Member

    i was editing my post to "ADD: did you copy the smash .htaccess file or code and upload it to kappa?" seems you have eliminated that one.

    did you try creating a new folder(s) to see if it acts any differently?
  7. CyclingTribe

    CyclingTribe Well-Known Member

    Not a caching issue is it? I've had similar and the favicon finally appeared a few hours later.
  8. Jaxel

    Jaxel Well-Known Member

    I moved /public_html/kappa to /public_kappa to further determine if its an htaccess issue... this is my htaccess in /public_kappa

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{HTTP_HOST} ^www\.yokappakappa\.com [NC]
        RewriteRule ^(.*)$ http://yokappakappa.com/$1 [L,R=301]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    and this is my config.php...
    $config['db']['host'] = '*****';
    $config['db']['port'] = '*****';
    $config['db']['username'] = '*****';
    $config['db']['password'] = '*****';
    $config['db']['dbname'] = '*****';
    $config['superAdmins'] = '1';
    $config['enableGzip'] = false;
    $config['cache']['enabled'] = true;
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions'] = array(
        'caching'                    => true,
        'lifetime'                    => 3600,
        'cache_id_prefix'            => 'kappa_'
    $config['cache']['cacheSessions'] = true;
    $config['cache']['backend'] = 'Memcached';
    $config['cache']['backendOptions'] = array(
        'compression' => false,
        'servers' => array(
                'host' => 'localhost',
                'port' => 11211,
                'persistent' => true,
                'weight' => 1,
                'timeout' => 5,
                'retry_interval' => 15,
                'status' => true,
  9. Fufu

    Fufu Well-Known Member

    comment out
     RewriteRule ^.*$ - [NC,L]
        RewriteCond %{HTTP_HOST} ^www\.yokappakappa\.com [NC]
        RewriteRule ^(.*)$ http://yokappakappa.com/$1 [L,R=301]
    2. removing 'favicon\.ico' from the rewrite rule
    3. if none of the rewrite rules are causing the problem, how about try changing the CHMOD permissions and see what happens
  10. CyclingTribe

    CyclingTribe Well-Known Member

    That will make both sites children of the public_html folder - any .htaccess applied at that level will apply to *both* sites.

    If you want to run them as two independent sites the conventional nomacleture is:


    So in your case I'd try setting them up as:


    This way you can have separate .htaccess and favicon files.

    Shaun :D
  11. Jaxel

    Jaxel Well-Known Member

    I am aware of that... but this is a cpanel addon domain... it defaults to putting it into /public_html because through cpanel you don't have access to anything below /home/<account>... but as I said in my previous post, I moved it to it's own public folder and the issue remained, even though there is no longer a parent .htaccess file.
  12. Steve F

    Steve F Well-Known Member

    When we had caching turned on on our site and then tried to run a dev install we had problems like you are describing.

    Even with caching turned off on the /dev/ it still would not work correctly and kept pulling URLs and images from the parent directory.

    Not sure if that helps any or not but once we disable all caching things worked as expected.
  13. CyclingTribe

    CyclingTribe Well-Known Member

    Ah, okay. (y)
  14. Jaxel

    Jaxel Well-Known Member

    None of this worked. As well, as I said before, this isn't specifically a favicon.ico issue. This is an ANY IMAGE OR HTML FILE issue. If any image or html issue exists in /public_html/smash, it will overwrite the one on /public_html/kappa

    Disabled caching on both websites... no difference. As well, /public_html/smash is NOT a parent directory to /public_html/kappa. They are siblings.
  15. CyclingTribe

    CyclingTribe Well-Known Member

    I'm not familiar with cpanel - but are you able to post the actual site configs/settings?
  16. Fufu

    Fufu Well-Known Member

    Do you need this in your .htaccess file?
    Options +FollowSymLinks

Share This Page