• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't figure out this server issue...

Jaxel

Well-known member
#1
Okay... I have two websites...

http://smash4u.net
http://yokappakappa.com

They are located at:
/public_html/smash
/public_html/kappa

They have favicon.ico here:
http://smash4u.net/favicon.ico (/public_html/smash/favicon.ico)
http://yokappakappa.com/favicon.ico (/public_html/kappa/favicon.ico)

The problem is the kappa icon shows the smash icon, instead of it's own. If I delete the smash icon, the kappa icon will start showing up, but the moment I reupload the smash icon, the kappa icon will get replaced again. What could be causing this issue?
 

Steve F

Well-known member
#2
Looking at the direct links the favicon show the same on both urls.

Code:
<link rel="shortcut icon" href="http://www.yoursite.com/favicon.ico?v=2" />
You can use that in PAGE_CONTAINER to force refresh on the favicon.
 

Jaxel

Well-known member
#3
Looking at the direct links the favicon show the same on both urls.

Code:
<link rel="shortcut icon" href="http://www.yoursite.com/favicon.ico?v=2" />
You can use that in PAGE_CONTAINER to force refresh on the favicon.
Not really pertinent to the issue... especially since there is no favicon shortcut in the page_container... it takes the file in the root.
 

Jaxel

Well-known member
#5
a shot in the dark... did you accidentally drop the smash 'favicon.ico' in the 'public_html' folder?
Nope... its not just favicon.ico... its actually ANY image and html file (doesn't seem to affect php files, which is why the websites themselves run fine). If the image/html file exists in /public_html/smash, it seems to overwrite /public_html/kappa. The moment I delete the file from smash, it works properly in kappa, but then smash is broken.

Based on this, I thought it was an htaccess issue... so I deleted the .htaccess in /public_html, /smash and /kappa (even though the .htaccess files in /smash and /kappa shouldn't affect one another)... and yet, the issue remained.
 

Fufu

Well-known member
#6
Nope... its not just favicon.ico... its actually ANY image and html file (doesn't seem to affect php files, which is why the websites themselves run fine). If the image/html file exists in /public_html/smash, it seems to overwrite /public_html/kappa. The moment I delete the file from smash, it works properly in kappa, but then smash is broken.

Based on this, I thought it was an htaccess issue... so I deleted the .htaccess in /public_html, /smash and /kappa (even though the .htaccess files in /smash and /kappa shouldn't affect one another)... and yet, the issue remained.
i was editing my post to "ADD: did you copy the smash .htaccess file or code and upload it to kappa?" seems you have eliminated that one.

did you try creating a new folder(s) to see if it acts any differently?
 

Jaxel

Well-known member
#8
I moved /public_html/kappa to /public_kappa to further determine if its an htaccess issue... this is my htaccess in /public_kappa

Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>
 
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
 
<IfModule mod_rewrite.c>
    RewriteEngine On
 
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
 
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
   
    RewriteCond %{HTTP_HOST} ^www\.yokappakappa\.com [NC]
    RewriteRule ^(.*)$ http://yokappakappa.com/$1 [L,R=301]
 
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
and this is my config.php...
Code:
<?php
 
$config['db']['host'] = '*****';
$config['db']['port'] = '*****';
$config['db']['username'] = '*****';
$config['db']['password'] = '*****';
$config['db']['dbname'] = '*****';
 
$config['superAdmins'] = '1';
$config['enableGzip'] = false;
 
$config['cache']['enabled'] = true;
$config['cache']['frontend'] = 'Core';
$config['cache']['frontendOptions'] = array(
    'caching'                    => true,
    'lifetime'                    => 3600,
    'cache_id_prefix'            => 'kappa_'
);
$config['cache']['cacheSessions'] = true;
 
$config['cache']['backend'] = 'Memcached';
$config['cache']['backendOptions'] = array(
    'compression' => false,
    'servers' => array(
        array(
            'host' => 'localhost',
            'port' => 11211,
            'persistent' => true,
            'weight' => 1,
            'timeout' => 5,
            'retry_interval' => 15,
            'status' => true,
        )
    )
);
 

Fufu

Well-known member
#9
try:
comment out
1.
Code:
 RewriteRule ^.*$ - [NC,L]
and/or
Code:
    RewriteCond %{HTTP_HOST} ^www\.yokappakappa\.com [NC]
    RewriteRule ^(.*)$ http://yokappakappa.com/$1 [L,R=301]
2. removing 'favicon\.ico' from the rewrite rule
3. if none of the rewrite rules are causing the problem, how about try changing the CHMOD permissions and see what happens
 

CTXMedia

Formerly CyclingTribe
#10
Okay... I have two websites...

http://smash4u.net
http://yokappakappa.com

They are located at:
/public_html/smash
/public_html/kappa
That will make both sites children of the public_html folder - any .htaccess applied at that level will apply to *both* sites.

If you want to run them as two independent sites the conventional nomacleture is:

/home/<user>/public_html

So in your case I'd try setting them up as:

/home/smash/public_html/
/home/kappa/public_html/

This way you can have separate .htaccess and favicon files.

Cheers,
Shaun :D
 

Jaxel

Well-known member
#11
That will make both sites children of the public_html folder - any .htaccess applied at that level will apply to *both* sites.

If you want to run them as two independent sites the conventional nomacleture is:

/home/<user>/public_html

So in your case I'd try setting them up as:

/home/smash/public_html/
/home/kappa/public_html/

This way you can have separate .htaccess and favicon files.

Cheers,
Shaun :D
I am aware of that... but this is a cpanel addon domain... it defaults to putting it into /public_html because through cpanel you don't have access to anything below /home/<account>... but as I said in my previous post, I moved it to it's own public folder and the issue remained, even though there is no longer a parent .htaccess file.
 

Steve F

Well-known member
#12
When we had caching turned on on our site and then tried to run a dev install we had problems like you are describing.

Even with caching turned off on the /dev/ it still would not work correctly and kept pulling URLs and images from the parent directory.

Not sure if that helps any or not but once we disable all caching things worked as expected.
 

Jaxel

Well-known member
#14
try:
comment out
1.
Code:
 RewriteRule ^.*$ - [NC,L]
and/or
Code:
    RewriteCond %{HTTP_HOST} ^www\.yokappakappa\.com [NC]
    RewriteRule ^(.*)$ http://yokappakappa.com/$1 [L,R=301]
2. removing 'favicon\.ico' from the rewrite rule
3. if none of the rewrite rules are causing the problem, how about try changing the CHMOD permissions and see what happens
None of this worked. As well, as I said before, this isn't specifically a favicon.ico issue. This is an ANY IMAGE OR HTML FILE issue. If any image or html issue exists in /public_html/smash, it will overwrite the one on /public_html/kappa

When we had caching turned on on our site and then tried to run a dev install we had problems like you are describing.

Even with caching turned off on the /dev/ it still would not work correctly and kept pulling URLs and images from the parent directory.

Not sure if that helps any or not but once we disable all caching things worked as expected.
Disabled caching on both websites... no difference. As well, /public_html/smash is NOT a parent directory to /public_html/kappa. They are siblings.