1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Can't change navlink color.

Discussion in 'Styling and Customization Questions' started by Matthew Hawley, Jun 30, 2013.

  1. Matthew Hawley

    Matthew Hawley Well-Known Member

    So I added this to EXTRA.css and it won't change it.

    Code:
    .navTabs .navTab.PopupClosed .navLink {
    color: white !important;
    }
     
  2. Andrej

    Andrej Well-Known Member

    It seems to work fine here. I even tried without the !important declaration and it still worked.

    Снимок экрана 2013-06-30 в 21.35.03.png

    Are you sure that you apply it to the correct style?

    Снимок экрана 2013-06-30 в 21.37.07.png
     
  3. Matthew Hawley

    Matthew Hawley Well-Known Member

    Yes I'm sure.
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Have you checked the EXTRA.css to make sure that it isn't defined elsewhere in it?
    And, if it is a custom style, have you checked any style specific .css for that to be defined in it with the !important tag?
     
  5. Matthew Hawley

    Matthew Hawley Well-Known Member

    It's a style I'm making and it's the only thing in EXTRA.css.
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    I just put that code in my EXTRA.css on 1.2 B3 and it worked fine (so it's not the code).
    Are you using CloudFlare (or something equivalent) that may need it's cache cleared? Have you cleared the cache on your browser?
     
  7. Matthew Hawley

    Matthew Hawley Well-Known Member

    No I don't use cloud flare or anything like that. I haven't cleared my browser cache, will do that later.
     
  8. Shelley

    Shelley Well-Known Member

    It should work. However, the fact you used !important when you didn't need to indicates you have something that is overriding this. Perhaps you modified a css template and applied an !important to the property.
     
    Tracy Perry likes this.

Share This Page