1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

can't access

Discussion in 'Troubleshooting and Problems' started by ThunderBird2, Apr 30, 2013.

  1. ThunderBird2

    ThunderBird2 Member

    Hi,

    I type my login on my website's login sidebar, I know it is correct, but didn't do anything, I try to put again. The response is "Log in/Sign up", it wouldn't let me to log in. Why?

    my ACP and cPanel access is working fine, just homepage log in.

    I check the box on ACP option- Basic Board re-direction--- "Use Full Friendly URLs
    If you enable this option, the links generated by the system will not include "index.php?". However, to enable this, mod_rewrite must be available and an appropriate .htaccess file must be in place.

    uncheck the friendly URL, it is now working. strange!
     
  2. 14DH01

    14DH01 Active Member

    clear your cookies in your browser,to see​
    Re​
    I answered too quickly I board not seen the end​
    You have to edit the htaccess file​
     
  3. Jeremy

    Jeremy XenForo Moderator Staff Member

    Do you have mod_rewrite enabled on your server? Did you upload the provided .htaccess file? Are you using Apache or nginx?

    I'm guessing you either don't have mod_rewrite enabled or a .htaccess file uploaded, since it works using index.php?url
     
  4. ThunderBird2

    ThunderBird2 Member

    I re-direct my website only without index.php, it is problem. They dont recognised my login access. what should I do. Which one better with or without index.php. I test Googles PageSpeed Insights to check speed of my website that suggest to change index.php for home website only.

    No, I didnt upload the .htaccess and also use Apache. I did clear up the cookies.
     
  5. 14DH01

    14DH01 Active Member

  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    You need to upload the .htaccess before you can use full-friendly URLs. XenForo comes provided with one that will work. Basically for /index.php?url and /url to be the same in the eyes of the server, it has to know how to route /url to /index.php?url in the background. Upload the .htacess file and you'll be able to login with that option turned on.

    XenForo comes provided with one. Those are for vB4 -> XF routing, which won't help in his case.
     
  7. 14DH01

    14DH01 Active Member

    if this is the url of the portal to access the administration panel, it can edit the file to indicate the correct url ?
     
  8. ThunderBird2

    ThunderBird2 Member

    Ahh I see, this is something new but rapid learning. I didnt see what change in my .htaccess that show for admin permission and bots block, what should I add there? mod_rewrite enabled? Should we have to follow each priority of Google InsightSpeed?
     
  9. Jeremy

    Jeremy XenForo Moderator Staff Member

    Nothing XenForo's codebase attempts to do will allow full friendly URLs to work without a proper .htaccess. The administration panel is still accessible with full friendly URLs enabled because they aren't rewritten to remove admin.php? from the URL, that will always remain.

    cPanel is also completely different software and can't 'help' except possibly creating a .htaccess file, which is unnecessary because XF comes with one provided. To solve ThunderBird2's issue, they can upload the .htaccess, verify they have mod_write enabled, and reactivate full friendly URLs.
     
    14DH01 likes this.
  10. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you upload the default .htaccess it'll reroute and Google will be none the wiser that all your pages are on index.php?. I'm not sure what you mean by admin permission and bots block tho.
     
  11. ThunderBird2

    ThunderBird2 Member

    I remove index.php in .htaccess file below, yes mod_rewrite is enabled.

    RewriteRule ^.*$ index.php [NC,L]

    replaced by

    RewriteRule ^.*$ [NC,L]

    ??

    If not, please show example of default .htaccess.
     
  12. 14DH01

    14DH01 Active Member

    you must leave the default htaccess XenForo.​
    add links in your domain for options rewrite url's via your ACP:​
    /admin.php?options/list/basicBoard​
    and​
    /admin.php?options/list/seo​
    :rolleyes: you need SEO working (ACP/options:rolleyes: )​
     
    ThunderBird2 likes this.
  13. Jeremy

    Jeremy XenForo Moderator Staff Member

    Your best bet is to redownload XenForo from the customer area, extract that .htaccess and upload it as is. This may also be of use: http://xenforo.com/help/friendly-urls/
     
  14. ThunderBird2

    ThunderBird2 Member

Share This Page