1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.0 Cannot use any other subdirectories ex. site.com/files/

Discussion in 'Troubleshooting and Problems' started by cynthetiq, Oct 13, 2011.

  1. cynthetiq

    cynthetiq Member

    I can't seem to use any directories that aren't part of xenforo, I get "The requested page could not be found."

    How can I work around this as I have the forum installed in the root directory and I'd like to install some other software on the same domain.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have any redirects set up in .htaccess?

    Can you give an example URL and what should load?
  3. cynthetiq

    cynthetiq Member

    The first example is http://thetfp.com/thetfp.png should load the logo I tried using that in the in header settings for the logo but it never worked. I worked around it.

    now I'm trying to move the chatrooms we used to have to http://thetfp.com/prochatrooms

    I'm using filezilla via sftp and I cannot see my .htaccess file. I know it's there.....
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Your URLS are being appended with a strange string of characters: #axzz1ac6UQbyE

    You need to investigate what is adding those characters.
  5. cynthetiq

    cynthetiq Member

    that's from tynt.com to track copied content. I removed it from the template and still doesn't work. I did try it with a fresh install the other day and still couldn't get it to work, which is what prompted me to post here.
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Looks fine to me. That image does not exist on the server so XenForo's rewrite rules are picking it up. The same thing happens here on xenforo.com:


    If that image existed in the community directory then it would load correctly.

    The solution is to upload that image to the server. It is currently missing.
  7. cynthetiq

    cynthetiq Member

    LOL I wish it was that simple. I see it on the server. Maybe it doesn't like .png files?

    vidchat.jpg is in the same directory and I can see that one.

    but what about...

  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The "prochatrooms" directory doesn't exist on your server so the request is being handled by xenforo. XenForo doesn't recognize that route so it says, "The requested page could not be found."
  9. cynthetiq

    cynthetiq Member

    but it does exist.....

  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Please post the contents of your ".htaccess" file.

    The default htaccess file (named "htaccess.txt") should not have this problem.
  11. cynthetiq

    cynthetiq Member

    Thanks guys. I thought I was going crazy because as you can see the directory I posted, it looks like it is there, but like jake said, it's not there. Confirmed by the server admin. I really thought I was going crazy but the files were going to my home directory only not to the rest of the structure.

    Mr. Brogan, can you close this thread?

Share This Page